RipGroove

Bottlenecked by 'Rendering Thread'?

118 posts in this topic
I used some spare time to try some things on the weekend t iron out some variables causeing this maybee on my end.

 

 

 

-The Problem is not OS limited win 7 as also win 10 has it.

 

-i tried the last 4 Driver versions with no significant changes in Performance.

 

-Borderless VS Fullscreen has no impact on FPS

 

-Text Streaming on/off has no impact on FPS but solves the FPS hickup a bit for me.

 

-clearing chaced data has no effect

 

-full Squad reinstall had no effect.

 

- FPS scale with GPU OC but not with CPU clocks clearly showing the limitig factor is the GPU.

 

-every other game i have on my PC is behaving normal and gives reasonable performance.

 

-my Itx rig with I7 4790 and GTX 1060 runs also into GPU limit pretty early .

 

 

 

My conclusion is Squad got somehow heavyer on GPU with V 9 without looking different.

 

 

 

Maybe a Dev could confirm or deny this ?

 

 

 

 

 

 

 

 

 

 

This pretty much mirrors exactly what I've found. The FPS decrease does seem a bit different for different people though which I guess is expected as all hardware is different.

 

The fact that my hardware simply destroys GTAV at 3440x1440 (with EVERYTHING maxed apart from MSAA which I've set to 2x) has just reminded me that my system is actually quite powerful and that my issues with Squad must be game related.

 

 

 

 

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
 

^A lot of people w/varying specs and even moderate to high end cards 1080, are reporting issues. All experienced a significant enough  FPS decrease with the v9.* update compared to v8.*. I hope this is given some attention by the DEV team in the next hot fix, at minimum get us back to v8.* FPS ranges. While my frames are currently tolerable, I much prefer my previous consistent 90 range (without sporadic dips below 60).



Same, although there are now a few maps that I literally have to leave the server if they come up as performance is 30-50fps so for now I'm stuck playing the better optimised maps such as Basrah and Sumari etc.

This is limiting me enough that I might just quit playing until the next update and see how things are then :-(


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

@RipGroove I can't remember if you built yourself the luscious watercooled build I saw on here a while ago and if so ignore this.

 

Have you tried swapping your GPU to another PCIe slot. I have heard of people suddenly getting better performance after doing so for some strange reason. You might want to give that a try if you're not tied in with WC plumbing.

Share this post


Link to post
Share on other sites
@RipGroove I can't remember if you built yourself the luscious watercooled build I saw on here a while ago and if so ignore this.

 

 

 

Have you tried swapping your GPU to another PCIe slot. I have heard of people suddenly getting better performance after doing so for some strange reason. You might want to give that a try if you're not tied in with WC plumbing.

 

My CPU has an all in one water cooler (NZXT Kraken), but my GPU is air cooled for now so I could try a different slot I guess.

 

 

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Posted (edited)

Check in which PCIe slot you plugged in your video card. One of your PCIe x16 slots works in 4x mode:

RFVHBcWSUGqus9z0_setting_000_1_90_end_50

 

https://www.asus.com/uk/Motherboards/TUF-Z270-MARK-1/specifications/

 

First PCIe works in x16 mode, second in 8x and third in 4x:

http://dlcdnet.asus.com/pub/ASUS/mb/LGA1151/TUF_Z270_MARK1/E11891_TUF_Z270_MK1_UM_WEB.pdf?_ga=1.182948262.1638301181.1491897526

bZj1P1x.png

qYNt6xm.png

 

You're using PCIe x16 video card.

 

 

Disable Hyper-threading

Disable HPET in BIOS and then in Windows:

bcdedit /deletevalue useplatformclock
bcdedit /deletevalue tscsyncpolicy
bcdedit /deletevalue disabledynamictick 

Delete(not disable) XBOX DVR and all other Windows 10 apps

Delete any third party antiviruses and firewalls, then turn off windows firewall, defender, UAC and all other crap Microsoft introduced in last versions of Windows.

 

Uninstall your video drivers using Display Driver Uninstaller. Install 372.90 Nvidia drivers(recommended by Epic driver for current version(4.14) of UE4 used in Squad) how this guy recommends in his post.

 

Then try all of this:

http://forums.guru3d.com/showthread.php?t=327922
http://forums.guru3d.com/showthread.php?t=406260
http://forums.guru3d.com/showthread.php?t=389072
http://forums.guru3d.com/showthread.php?t=378044
http://forums.guru3d.com/showthread.php?t=376458
https://steamcommunity.com/app/207380/discussions/0/792923684230105784/
http://forums.guru3d.com/showthread.php?t=401262
http://www.overclock.net/t/1433882/gaming-and-mouse-response-bios-optimization-guide-for-modern-pc-hardware
http://www.overclock.net/t/1372936/guide-disable-nvidia-scaling-and-reduce-input-lag
http://steamcommunity.com/sharedfiles/filedetails/?id=475747492

 

Also, while tweaking your BIOS and windows I would follow the rule 'turn it off and better delete it if I don't use it'.

 

Don't read only first post. Read through all threads(yes, I know, some thread are 300+ pages long). There are a lot of stuff which can help you to boost your FPS.

 

Disclaimer to all skiddos who say windows tweaks don't work: some of the settings in BIOS or Windows, obviously, causing so low frame rates(or 'hardware setting', as number of PCIe slot in use) for RipGroove. How do you fix low frame rates, then? Correct, by changing settings.

By using incorrect settings(or tweaks, if you want to call them that) you can easily drop your frame rates drastically(like using HPET in Bios and/or in Windows in wrong combination or turning off/on Hyper-threading, etc.

 

Have fun tweaking.

Edited by Skul

Share this post


Link to post
Share on other sites

Posted (edited)

On 02/04/2017 at 10:46 PM, Helwyr said:

All you'll get here is 

"Overclock your CPU"

"Overclock your RAM"

"Upgrade parts!"

Nope. You're wrong.

 

On 02/04/2017 at 10:46 PM, Helwyr said:

Go to the discord and ask in the support channel, it's the best bet to get an answer from someone who actually knows what they're talking about

lol uwutm8? People on forums are generally smarter than people on any other media: social networks(facebook, twitter, whatever) and chats.

True professionals in their science are sitting on the forums in particular: professional programmers sit on forums dedicated to programming; professional gamers sit on the forums for professional gamers(such as ESL, ESEA, for example) or on the forums dedicated to some particular game they play; professional paintball players sit on the appropriate forums; professional technicians(hardware grease monkeys) sit on hardware forums; professional cooks sit on appropriate forums, and I could continue this list for the rest of my life and not end it. Professionals don't sit on systems(in terms of sharing their professional experience and knowledge, with some exceptions, course) made for casuals, such as Facebook, Skype or Discord.

 

Considering that problem TS has is about game Squad, I say that there is no better place to ask this question than this forums at the moment. And that Discord thing you proposed is a joke lul sarcastic_hand.gif

Edited by Skul

Share this post


Link to post
Share on other sites

Skul - you are a nerd of the highest order Sir! great work.

Share this post


Link to post
Share on other sites
52 minutes ago, Skul said:

Disclaimer to all skiddos who say windows tweaks don't work: some of the settings in BIOS or Windows, obviously, causing so low frame rates(or 'hardware setting', as number of PCIe slot in use) for RipGroove. How do you fix low frame rates, then? Correct, by changing settings.

 

Except none of these pointless settings have changed, he's getting low fps since v9, v8 worked fine for him. Most of these "tweaks" are just hilarious bullshit.

Share this post


Link to post
Share on other sites
Check in which PCIe slot you plugged in your video card. One of your PCIe x16 slots works in 4x mode:

RFVHBcWSUGqus9z0_setting_000_1_90_end_500.png

 

https://www.asus.com/uk/Motherboards/TUF-Z270-MARK-1/specifications/

 

First PCIe works in x16 mode, second in 8x and third in 4x:

http://dlcdnet.asus.com/pub/ASUS/mb/LGA1151/TUF_Z270_MARK1/E11891_TUF_Z270_MK1_UM_WEB.pdf?_ga=1.182948262.1638301181.1491897526

bZj1P1x.png

qYNt6xm.png

 

You're using PCIe x16 video card.

 

 

Disable Hyper-threading

Disable HPET in BIOS and then in Windows:

bcdedit /deletevalue useplatformclockbcdedit /deletevalue tscsyncpolicybcdedit /deletevalue disabledynamictick 

Delete(not disable) XBOX DVR and all other Windows 10 apps

Delete any third party antiviruses and firewalls, then turn off windows firewall, defender, UAC and all other crap Microsoft introduced in last versions of Windows.

 

Uninstall your video drivers using Display Driver Uninstaller. Install 372.90 Nvidia drivers(recommended by Epic driver for current version(4.14) of UE4 used in Squad) how this guy recommends in his post.

 

Then try all of this:

http://forums.guru3d.com/showthread.php?t=327922
http://forums.guru3d.com/showthread.php?t=406260
http://forums.guru3d.com/showthread.php?t=389072
http://forums.guru3d.com/showthread.php?t=378044
http://forums.guru3d.com/showthread.php?t=376458
https://steamcommunity.com/app/207380/discussions/0/792923684230105784/
http://forums.guru3d.com/showthread.php?t=401262
http://www.overclock.net/t/1433882/gaming-and-mouse-response-bios-optimization-guide-for-modern-pc-hardware
http://www.overclock.net/t/1372936/guide-disable-nvidia-scaling-and-reduce-input-lag
http://steamcommunity.com/sharedfiles/filedetails/?id=475747492

 

Also, while tweaking your BIOS and windows I would follow the rule 'turn it off and better delete it if I don't use it'.

 

Don't read only first post. Read through all threads(yes, I know, some thread are 300+ pages long). There are a lot of stuff which can help you to boost your FPS.

 

Disclaimer to all skiddos who say windows tweaks don't work: some of the settings in BIOS or Windows, obviously, causing so low frame rates(or 'hardware setting', as number of PCIe slot in use) for RipGroove. How do you fix low frame rates, then? Correct, by changing settings.

By using incorrect settings(or tweaks, if you want to call them that) you can easily drop your frame rates drastically(like using HPET in Bios and/or in Windows in wrong combination or turning off/on Hyper-threading, etc.

 

Have fun tweaking.


Thanks, I've actually already done all that anyway as a matter of course except those threads you've linked to so I'll have a read through those! :-)


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
6 minutes ago, banOkay said:

 

Except none of these pointless settings have changed, he's getting low fps since v9, v8 worked fine for him. Most of these "tweaks" are just hilarious bullshit.

and some arn't, it's very system specific of course. But settings tweaks helped me alot when I started on a lower spec system.

So let the forum be a place for information, it will help some more than others, but let it be.

Share this post


Link to post
Share on other sites

Seeing as it was mentioned, im running 6700k at 4.9GHz and a GALAX HOF 1080 at 2100MHz and the card is in a 8x slot :P

 

The difference in performance is tiny, if noticeable at all compared to 16x PCI-E slow.

Reason is my CPU cooler vs video card space. The HOF card is HUGE and I have a NH-D15.

Share this post


Link to post
Share on other sites

Just run GPU Z and check your PCIE bandwith if you are not sure (check with redering test on otherwise power save featues lead to a wrong result ), lol no need to swapp around stuff in the case.

 

Skull stop giving such arkwart "snakeoil" Hin`ts

 

-Don´t change SMT( could have bought a 7600K then lol, but even ppl with HT less CPUs run in these troubles)  and HPET settings that`s bullshit .

-OFC you disable all savety features in software, like firewall,defender wright your Visa pin on the forum e.g. xD

 

All other games run fine, Squad ran better in V8.X but it must be your rig, some bios settings that are burried deep in the menus and you did`nt even know of them nor what they do should be the root cause suddenly ,lol seriously ???

 

With just common sense you can see thats a Squad software **** up and nothing is wrong with your rig.

 

 

Share this post


Link to post
Share on other sites

All help is appreciated lads, any suggestion is at least worth a look.

FYI I have HT disabled anyway for two reasons, most of my games play better with it disabled and I can run a stable overclock at 5.0GHz with it off due to temps being 15°C lower, for me the increase in clock speed outweighs the benefit of HT, at least for gaming anyway.

There is some logic to 'it's your rig' as some people are suffering worse than others with v9 so in theory it can't 'all' be down to the game itself. I've seen this before in many games, an update will cause issues for some and not others, sometimes it can be fixed by tweaks at the users end and sometimes you simply have to wait for the next game update and see if it runs better with your exact hardware configuration.

Personally after running numerous benchmarks and other games and having zero issues I'm starting to think that this time around Squad just isn't playing well with my exact configuration for some unknown reason. I will keep trying different things as if you don't try you'll never get to the bottom of it.

Sadly though as I mentioned there are too many maps that currently return 30-40fps average for me currently to the point I have to leave the server when they pop up so it's just not viable for me to play as much as I spend too much time server hopping and not getting settled. Hopefully there will be an update soon and hopefully it'll help me out a bit.

Just to add I am actually pretty pissed that the very next day after get my new PC running (after spending A LOT of money on parts) v9 gets released and buggers everything up lol. I have to laugh or I'll cry as I pretty much built this PC for Squad. At least it's almost Summer now though so I won't be constantly indoors glued to Squad, unless my performance gets better all of a sudden.

Anyone want to buy £2000+ paperweight lol (jk)




Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
5 hours ago, RipGroove said:

Sadly though as I mentioned there are too many maps that currently return 30-40fps average for me currently to the point I have to leave the server when they pop up so it's just not viable for me to play as much as I spend too much time server hopping and not getting settled. Hopefully there will be an update soon and hopefully it'll help me out a bit.

What's your CPU and GPU usage when your FPS drops down to 30-40?

My FPS drops down to 30-40 and GPU usage drops down to 60% if I alt-tab or write something in chat. The only thing I can do to get my FPS back is to restart the game. It is inconsistent and doesn't happen all the time, so it was very hard to troubleshoot. As a temporary 'fix' I found out that if I press enter(open spawn screen), then I can type in chat and alt-tab, and it will not drop my FPS.

Before that I also switched to borderless mode and it had similar effect.

Share this post


Link to post
Share on other sites
5 hours ago, moppel said:

Just run GPU Z and check your PCIE bandwith if you are not sure (check with redering test on otherwise power save featues lead to a wrong result ), lol no need to swapp around stuff in the case.

 

Skull stop giving such arkwart "snakeoil" Hin`ts

Yeah, like why would he try to plug his x16 video card to PCIe x16 slot instead of PCIe x4/x8 slot. It doesn't make sense at all. kek.

 

5 hours ago, moppel said:

All other games run fine, Squad ran better in V8.X but it must be your rig, some bios settings that are burried deep in the menus and you did`nt even know of them nor what they do should be the root cause suddenly ,lol seriously ???

 

With just common sense you can see thats a Squad software **** up and nothing is wrong with your rig.

Have you ever heard of term 'compatibility issues'?
Once they update engine version, game version and EAC version, that is a very different game than what it was before update. So it can have new compatibility issues(like with HT or video drivers). And in fact, every single update Squad has new compatibility issues either with drivers or other programs.

Share this post


Link to post
Share on other sites
14 hours ago, Skul said:

Nope. You're wrong.

 

lol uwutm8? People on forums are generally smarter than people on any other media: social networks(facebook, twitter, whatever) and chats.

True professionals in their science are sitting on the forums in particular: professional programmers sit on forums dedicated to programming; professional gamers sit on the forums for professional gamers(such as ESL, ESEA, for example) or on the forums dedicated to some particular game they play; professional paintball players sit on the appropriate forums; professional technicians(hardware grease monkeys) sit on hardware forums; professional cooks sit on appropriate forums, and I could continue this list for the rest of my life and not end it. Professionals don't sit on systems(in terms of sharing their professional experience and knowledge, with some exceptions, course) made for casuals, such as Facebook, Skype or Discord.

 

Considering that problem TS has is about game Squad, I say that there is no better place to ask this question than this forums at the moment. And that Discord thing you proposed is a joke lul sarcastic_hand.gif

TLDR. 

 

SuicidalChair is the only person who actually helps with tech support from what I've seen. 

Also shove that smug "we're smarter because we're on a forum xD" thing right back where it came from

Share this post


Link to post
Share on other sites

Calm down lads, be nice.

 

Forum Rules

Section I: Posting Rules
§1 Show Respect
This community can only work if we all respect each other. To that end, it is imperative that any time you engage with another user, either directly or indirectly, you show them respect with the content of your post. In particular refrain from flaming, insulting, abusing, taunting, and other similar types of actions towards other forum users.
§2 Attitude & Behavior
Poor attitude and behavior are the most common ways a negative / unsafe environment is created and perpetuated. As such that kind of behavior will not be allowed on these forums. Please be mindful of this rule when posting personal positions and opinions regarding topics which could be considered contentious in nature. As a rule of thumb, keep your posts civil in nature, and refrain from making posts that are likely to incite arguments and create a negative environment. As a privately hosted web forum we reserve the right to maintain an environment that we are happy the majority of our players are comfortable with.
§3 Swearing
While we will not strictly moderate every little swear that occurs, please try to avoid excessive bad language. The moderation reserves the right to remove rants and unsuitable content at any time.

Share this post


Link to post
Share on other sites

Guys please don't get the thread locked by pissing each other other off. As I said ALL suggestions are welcome as although I've been PC gaming a long time there will obviously be things I've forgotten or missed with this new build.


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now