Jump to content
marsarmy47

Squad V9 Performance issues and long loading time!

Recommended Posts

Hey Guys,recently like everyone i got V9 after launching i'm getting frames dropes from 50 fps to 2 or 1 frames that last about 3 secs then it goes up then it happens everytime,and also joining servers take like 5 min++,the game is completly unplayable i thought it was going to be a fleshed update but it's the worst so far i'm playing at epic settings like before

i used to get (45-100 fps)

my system:

i5 4460 3.2 ghz

sapphire amd r9 280x 3gb tri-x oc

8gb ram ddr3 1600 mhz

(ps:game is installed on a hdd)

 

Share this post


Link to post
Share on other sites

Same. Loading times are fine, but I can barely connect to any servers and I get small frame stutters frequently.

Share this post


Link to post
Share on other sites

I'm also not happy with the game performance, but I don't have the problems you mentioned.

 

I have a way too low FPS if you ask me. Around 30 FPS.

GPU stays at 100% when playing Squad, CPU at 40-50%

 

i5 3570, 3.4 GHz

16 GB RAM, 1600 MHz DDR3

GTX 1060

Win 10

 

I tried almost everything. These are my settings

 

 

Share this post


Link to post
Share on other sites

I noticed that during the most recent update, I was also getting those random drops from 40/50 fps down to single digits, generally for just one second or less.

This pointed to a memory issue and so I did some checking, and in v9.1 after five minutes in a server, squad had a 6.3 gb memory footprint. As I only have 6gb of memory, it was hitting my page file very often. When the hdd that my page file was on was getting a little overloaded with a large number of passing requests, my fps would drop quite dramatically.

I switched my page file over to my ssd and my sporadic frame drops have been practically eliminated.

For skull crusher, overclocking your cpu may be of real value

Share this post


Link to post
Share on other sites

But my CPU stays at 40%. How can it bottle neck me? 

Also, my CPU stays at 60 degrees at the moment, I'm not sure if I should overclock. 

Edited by Skullcrusher

Share this post


Link to post
Share on other sites

Even when your total CPU usage is 40% this can translate in 1 core 95% usage  and the left overs running around 20% resulting in ~40% total.

As we know squad is very Singelcore heavy so increasing CPU clock can help a bit but dont ecspect wonders.

With a constant 100%GPU usage with maximum stable Clock as you wright  its unlikely you win much FPS.

Share this post


Link to post
Share on other sites
15 hours ago, moppel said:

Even when your total CPU usage is 40% this can translate in 1 core 95% usage  and the left overs running around 20% resulting in ~40% total.

As we know squad is very Singelcore heavy so increasing CPU clock can help a bit but dont ecspect wonders.

With a constant 100%GPU usage with maximum stable Clock as you wright  its unlikely you win much FPS.

I just tested this and it seems that all my cores are pretty equal.

 

I made some screenmshots:

 

n12h5f.jpg

 

14e1chs.jpg

Share this post


Link to post
Share on other sites

both screens show 99% GPU Usage(Dont see its clocks but i imply its max Clocks) , showing that your FPS are Limited by the GPU in this moment. reduce the Supersampling this should help

Share this post


Link to post
Share on other sites

I run a potato laptop so was happily in the 30-40 fps range, however since V9 it has dropped to 15-22 - that is my burden and I'll forgo the traditional call and response around having an outdated laptop however while trying to get to the bottom of this I found something interesting which may be related, although I am not nearly computer savvy enough to know if it is or not.

 

As above, I have an older CPU but the usage is never above 50% or so (as above it is not merely showing an average of a number of cores), GPU usage similar, and while GPU memory is around 80% (a mere 2GB) usage it never goes above that.

 

When watching the process explorer I noticed the lag spikes coincide with a huge spike (coming from Squad) in the usage of system commit - it will jump from 8-10GB to 16GB above the current amount allotted. All other variables - CPU/GPU/Physical Memory/Network remained the same - and as reliable as clockwork whenever there was a spike in the system commit (usually 6GB for a few seconds) then the spikes in FPS would continue.

 

I have no other speculations around how/why, except that this is solely confined to Squad and since V9. Perhaps this observation will help people, probably it won't but I'll put it on record and this has been my morning and I will like to pretend I have been productive.

Edited by RandomUser456
clarification

Share this post


Link to post
Share on other sites
16 hours ago, moppel said:

both screens show 99% GPU Usage(Dont see its clocks but i imply its max Clocks) , showing that your FPS are Limited by the GPU in this moment. reduce the Supersampling this should help

16h2p8l.jpg

 

 

This might not be clear enough. It's 1898 MHz at 99% GPU with 37.5 FPS.

 

I am currently using 1.75x super sampling, and with 2.0x it is close to unplayable. Of course, I wanted to max everything.

The question is: isn't this hardware enough for this game...? Or am I doing something wrong with my settings somewhere.

Edited by Skullcrusher

Share this post


Link to post
Share on other sites

No. At this point in the development, your hardware is likely not enough to run it absolutely maxed out.

 

1060 is not sufficient to render games at near 4K resolution with high graphical fidelity. Assuming you're running a 1080p monitor and running 1.75x super-sampling, you are effectively rendering the same amount of pixels as three 1080p monitors.

Your CPU is also getting some age on it's back. Couple those factors with the fact that the game could still use some optimization, you are not likely to be running this game maxed out at this moment.

Edited by Didgy
Typo

Share this post


Link to post
Share on other sites
22 hours ago, Skullcrusher said:

16h2p8l.jpg

 

 

This might not be clear enough. It's 1898 MHz at 99% GPU with 37.5 FPS.

 

I am currently using 1.75x super sampling, and with 2.0x it is close to unplayable. Of course, I wanted to max everything.

The question is: isn't this hardware enough for this game...? Or am I doing something wrong with my settings somewhere.

Turn Supersampling off or at least down to a point where you leave GPU limit. 2.0 is OFC harder on your frames then 1.75 , with this setting yor GPU has to render in  ~ 4k resolution ,thats too much for a GTX1060 even 1080 cards struggle in these resolution areas.

 

Beside this Squad just runs horribad , even highest tier rigs have problems with performance . Just skip it till next patch and check back if something got better.

 

Share this post


Link to post
Share on other sites

it's fixed now guys,i'm really enjoying the game now more than before i take back what i said about this update but thanks for replying guys

Share this post


Link to post
Share on other sites
27 minutes ago, marsarmy47 said:

it's fixed now guys,i'm really enjoying the game now more than before i take back what i said about this update but thanks for replying guys

 

What did you do to Fix-it,so others may benefit?. :)

 

Share this post


Link to post
Share on other sites
On 16/04/2017 at 10:54 PM, Xx-RAGING-DEATH-xX said:

 

What did you do to Fix-it,so others may benefit?. :)

 

i really don't know it just got fixed perhaps the auto fixes ? :

Share this post


Link to post
Share on other sites
On 8.4.2017 at 10:12 AM, Skullcrusher said:

I just tested this and it seems that all my cores are pretty equal.

 

I made some screenmshots:

 

n12h5f.jpg

 

14e1chs.jpg

What's the name of that program?

Share this post


Link to post
Share on other sites
On 23.4.2017 at 7:49 PM, Chez said:

What's the name of that program?

I think MSI Afterburner.

Share this post


Link to post
Share on other sites
On 4/24/2017 at 2:49 AM, Chez said:

What's the name of that program?

 

5 hours ago, beginna said:

I think MSI Afterburner.

 

I don't know if Afterburner can do it to, but the only program I have ever seen give those pink stats is Rivatuner, but I am basing that off 9 year old information

 

(You can see it in the top right of this clip)

 

 

Share this post


Link to post
Share on other sites

LOL.

 

I'm actually using both of them (MSI Afterburner and Rivarturner Statistics).

I don't remember how I installed them, I made some research back then, but they work together somehow.

Edited by Skullcrusher

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×