Jump to content
RipGroove

V9 Performance issues anyone? Or just me?

Recommended Posts

Posted (edited)

Yesterday before the update this was my performance:

 

3440x1440

Full servers

All settings maxed except no AA or SuperSampling

60fps minimum (under heavy fire and smoke)

70-80fps average

Highs of 150+fps

ShadowPlay On

Hyperthreading ON (Hadn't got around to switching it off yet on this build)

Smooth fps generally with the odd slight stutter every 30secs to 1min

 

 

Before the update I deleted the Squad folder from %localappdata% as advised, and this is my performance today:

 

3440x1440

Low population and full servers

All settings maxed except no AA or SuperSampling

30fps minimum (under heavy fire and smoke)

50-60fps average

Highs of 85+fps

ShadowPlay Off

Hyperthreading ON/OFF makes no difference

Texture Streaming ON/OFF makes no difference

Lots of small rubber banding/lag/stutter

 

Now that's quite a drop in performance. Also fps seems very erratic, where it was almost a constant 80ish before its now peaking and diving from 30-60 all the time. This is a new PC build that hasn't changed overnight and is scoring the same today as it did yesterday on Firestrike (15000+).

 

Here's my hardware specs but I very much doubt it's at fault because the game was clearly running great until the update, the only thing in the back of my mind is my GPU, maybe the 980ti just can't handle the game that well since the update? I'm patiently waing for the EVGA 1080ti Hybrid so maybe that will help:

Spoiler

OS - Win 10 Home
Mobo - ASUS TUF Z270 Mark 1
CPU - Intel i7-7700k @ 4.9GHz
CPU Cooler - NZXT Kraken X62
RAM - 16GB Corsair Dominator Platinum 3000MHz
GPU - EVGA 980ti FTW (Stock Clocks)
SSD - M.2 Samsung 960 EVO 500GB
PSU - Corsair RMi 850w

 

Gorodok has been the worst map so far where even with only 38 players in the server my fps was 30-40, I actually had to leave the game earlier because even with G-Sync 30-40fps is unplayable.

 

Edited by RipGroove

Share this post


Link to post
Share on other sites

Yes it has taken a hit on frames but this will be ironed out! We'll probably have a few updates over the next few weeks like in the other versions

 

its mainly bad on the big maps 

Share this post


Link to post
Share on other sites
Yes it has taken a hit on frames but this will be ironed out! We'll probably have a few updates over the next few weeks like in the other versions

 

its mainly bad on the big maps 


Yeah hopefully that's the case then.


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
Posted (edited)

Some more people including me are getting some really nasty stuttering and random freezes during firefights. The game is pretty much unplayable.

Edited by Marijuanoz

Share this post


Link to post
Share on other sites
35 minutes ago, Marijuanoz said:

Some more people including me are getting some really nasty stuttering and random freezes during firefights. The game is pretty much unplayable.

I started getting that before the update. It might be more related to the server than the update.

Share this post


Link to post
Share on other sites
I started getting that before the update. It might be more related to the server than the update.


I had zero problems before the update, no disconnects and no performance issues.


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
55 minutes ago, RipGroove said:


I had zero problems before the update, no disconnects and no performance issues.


Sent from my iPhone using Tapatalk

What I meant was that kind of stuttering seemed like it was more a random occurrence based on what server you were connected to rather than related to the update. I got the stuttering for a few games and then when I got on the next day (this was all before the update) it was gone. I don't think the update had an effect.

Share this post


Link to post
Share on other sites
What I meant was that kind of stuttering seemed like it was more a random occurrence based on what server you were connected to rather than related to the update. I got the stuttering for a few games and then when I got on the next day (this was all before the update) it was gone. I don't think the update had an effect.


I'm definitely getting a lot of stutter since the update for sure. I had almost none before but it's quite irritating now.


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
Posted (edited)

yup never had such issues got over 1000 hrs on the game... my pc is crap so play it on low settings normally anyway.. but the big issue I see now is that the game is suddenly maxing out my CPU/memory .. never had this before so its since the update.  normally runs at about 25 % cpu and 30 60% memory .. now hitting 90 - 91 % .. at times 6 Gigs of memory.. never has it done that normally around 2.5 3 gigs.  .. no idea whether thats the culprit as I know nothing about pc's tbh.  (just closed the game and my cpu is 1% and 18% memory..) unfortunately cant play the game like that so will wait to see what comes out of the patches.

Edited by embecmom

Share this post


Link to post
Share on other sites

GTX 970, 8 gig, i5 6600.

1.25 supersampling and FXAA, all else is maxed 1080.

FPS still seems consistent, it's never been slow enough for me to want to check but since the update there are huge hangs right when I fire or something blows up, then we're back to normal for a couple minutes. Game definitely looks and sounds better though, and I like the punchy acceleration on the vehicles. Really surprised with v9.

Share this post


Link to post
Share on other sites
3 hours ago, Marijuanoz said:

Some more people including me are getting some really nasty stuttering and random freezes during firefights. The game is pretty much unplayable.

The game is definitely unplayable. I can't join most servers, I am getting random stutters, and what seems like lag even with low ping

Share this post


Link to post
Share on other sites
3 minutes ago, Helwyr said:

The game is definitely unplayable. I can't join most servers, I am getting random stutters, and what seems like lag even with low ping

*hugs*

Share this post


Link to post
Share on other sites
5 minutes ago, Marijuanoz said:

*hugs*

It'll be okay, the 10 eventual hotfixes might fix the issues

Share this post


Link to post
Share on other sites
The game is definitely unplayable. I can't join most servers, I am getting random stutters, and what seems like lag even with low ping


System specs?

Sent from my SAMSUNG-SM-G920A using Tapatalk

Share this post


Link to post
Share on other sites
Posted (edited)
2 hours ago, Soulzz said:


System specs?

Sent from my SAMSUNG-SM-G920A using Tapatalk
 

 

6600 at 3.7ghz

8gb of RAM

1070.

 

My main issue is being unable to join servers.

Edited by Helwyr

Share this post


Link to post
Share on other sites

Does someone who doesn't have a real custom set of controls and slow internet want to try to uninstall and reinstall Squad and see if it fixes it?

I would but my controls are so weird that it takes ages to set them up again, plus it takes me about 7hrs to download Squad :-(

Actually I'll copy Squad from my SteamApps folder and do a reinstall like that and see if it helps.


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Well, reinstall made no difference.

I've also noticed when firing some rifles and vehicle turrets (especially zoomed in) that FPS drops by about 40! As soon as I stop firing it goes back up again.

50fps on Sumari when I used to get 100+

Kind of glad it's not just a problem at my end, sucks for everyone though. Hopefully there will be a hotfix for this issue soon.



Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Mine has also taken a performance hit. Lots of stuttering during intense fire fights. 

Share this post


Link to post
Share on other sites

I wonder if it's a massive memory leak on certain maps as I've just played for 45mins in a full server at Logar against a massive super fob and averaged 80fps with dips to 50+ inside the super fob in all the smoke and chaos which I thought was pretty good.

 

Share this post


Link to post
Share on other sites
14 hours ago, Migillis said:

GTX 970, 8 gig, i5 6600.

1.25 supersampling and FXAA, all else is maxed 1080.

FPS still seems consistent, it's never been slow enough for me to want to check but since the update there are huge hangs right when I fire or something blows up, then we're back to normal for a couple minutes. Game definitely looks and sounds better though, and I like the punchy acceleration on the vehicles. Really surprised with v9.

 

same issues here, along with around 10fps drop comparing to v8, also experience these weird freezes which are especially irritating during firefights.

HW: GTX 1060 6g, 16g ram, i5-3550

 

 

Share this post


Link to post
Share on other sites

Didnt really get a drop in FPS. I was always around 60. But i have massive stuttering. To quick to really effect fps counter. Hope it will be fixed in a patch.

Share this post


Link to post
Share on other sites

I will post this again, this time on forum:

 

My problem started with v6 version. I got 3-5s freezes after every ~30s. Then some hotfix came out and problem was partially solved. From that time when round starts and I respawn in main base, I got big freezes for about one minute. After that everything was ok, but if round ended and map changed (even to the same), I got short freezes in whole match. Solution was to disconnect and reconnect to the server - then freezes was again only on round start.

Now in v9:

On Firing Range after changing map: Big freezes when shooting and ground, objects; when moving camera in air on admincam.

Example from yesterday CCFN:

Rounds starts, I get in Humvee and drive to the center of the Chora. I leave the vehicle and got one mega 1 minute freeze (I thought my pc gonna explode). After that another big freezes for total time of 3-4 minutes. After this I got smaller freezes when I shoot, when something explodes far away or close to me, when I turn around quickly or enter area of the map that I've didn't been before.

I didn't reconnected for the second round. There was again freeze on spawn, and some smaller freezes later in the match, but in overall "performance" was about 50% better that in round 1.

Before I started the game, I restarted PC so RAM was not used by any other software. Ofcourse I cleared game cache earlier. Lowering video settings didn't helped, and if not that freezes, I got mostly +60 fps.

Share this post


Link to post
Share on other sites

I've had a big fps drop as well. From 70 avarage to 45-50. This is on full servers. 

 

Really cant enjoy a game with less then 60 fps -.-

 

I get 80-100 fps on bf1 full servers.. 

 

Share this post


Link to post
Share on other sites

i5-6600K @ 4.7Ghz
GTX 1050 2GB
8 GB DDR4

 

Game is constantly lurching/lagging and stuttering making skillful firefights impossible and looks pretty retarded.

Glad penetration is in but something is wonky af this update brought my FPS from a pretty solid 60 (vsync) (without it's 70-120, dropping as low as 45-60 depending on vehicle and firefight conditions and how long we've been playing on the map) to bouncing between 30/60 (it would appear anyway)

Share this post


Link to post
Share on other sites

Runs better for me now believe it or not I use to run on low graphics to stop the stutter lag every few seconds ..Now I run on high graphics and it runs fine

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×