Jump to content

Recommended Posts

Hi, I created an account just in order to ask what is wrong with my game. My specs are:

 

Intel i5 4440s 2.8 ghz

MSI Nvidia gtx 950 2gb

6 gigs ram

 

I updated my drivers, restarted my pc, and defraged the disk but still nothing works. I've tried many fixes and workarounds but the highest fps I've gotten was 30 when i was in the corner of the map with nothing nearby. I tried the game once more earlier and even though everything looks like it's made of play-doh I get a (1) frame per second. The only thing that I have noticed is that Squad maxes out on ram when I try to use it. In all my other games: Rainbow Six, Battlefield 4, Overwatch, TF2, Left 4 Dead 2, etc. I get 60 fps easy so I don't know why this game barely even displays a picture. Any input or help would be appreciated.

Share this post


Link to post
Share on other sites

Which OS? I believe 6g of ram falls short of what is really needed. My W10  pc idles after startup using around 4g of my 16g of ram. The CPU could be better too.

 

 

EDIT. Oh, and what Sorta said. Next version release should be better.

Edited by CC-Marley

Share this post


Link to post
Share on other sites
Arcapse   

Squad won't be as well optimised in it's current state as those other AAA games.

 

That and your CPU is bottlenecking your performance as Squad is very taxing on the CPU.

Share this post


Link to post
Share on other sites
Psyrus   
Which OS? I believe 6g of ram falls short of what is really needed. My W10  pc idles after startup using around 4g of my 16g of ram. The CPU could be better too.

6 gb is more than enough. This is from a 6gb ram user

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×