Jump to content
=MM= Bandaid

EAC Launch error "untrusted system file"

Recommended Posts

I have found the source of what is causing my integrity violation for explorerframe.dll.

 

A patcher I use to replace the hideous ribbon that has been implemented in recent Windows with the nice, simple command bar Ribbon Disabler is patching the DLL and backing it up.

 

Now, I could unpatch it each time I want to play Squad (in which doing so I would have to log out and back in), but that seems excessive for something as lackingly insidious as a patched explorerframe.dll.

 

db0da7aca0cf416b88aa10f2e02e6e75.png         I think it is clear why anyone would want to do this...

 

So, what can EAC do about this?  It would be nice to have the DLL whitelisted.  Until then, I guess my money to Commander Founders Edition has just gone to waste.

Edited by yurisuika

Share this post


Link to post
Share on other sites
22 hours ago, Salti said:

Turned off.... all the skins....worked.

That solution works for the issues people have been getting recently from the squad update that was pushed, where the steam inventory crashes with squad, according to the devs themselves on discord. The issue we have has not yet been solved by anything less than reinstall unfortunately. 

Share this post


Link to post
Share on other sites

I never had any skins installed and this issue is largely unlikely to be due to skins.

 

There's .dll files all over the place that are flagging on EAC. I don't know how my DXGIDebug, could be anything but correct since I've reinstalled Direct X and found a replacement .dll when that didn't work. 

 

Any Moderator's want to comment? Or is the Software Support forum for show?

Share this post


Link to post
Share on other sites

Thank you Mod for replying. Bumping this post to bring it to attention. I love this game, used to play it every day and since the EAC update it's been broken.

Please help us fix this!

Share this post


Link to post
Share on other sites

I'm still having the problem but I remember something about a project reality audio fix that might have had something to do with the xaudio files. Anyone else remember similar?

 

Edit: crap, I had to install some sort of "dts ddl fix" to get surround sound working in a few games. IIRC it required me to replace the xaudio dlls. I need Squad to work without reversing this fix.

 

Edit 2: just remembered what happened. I had to install a fix for Witcher 3 for surround sound. Googling Witcher 3 surround sound fix gives you a page instructing you to download edited xaudio files and says the fix works for other games as well. I will not be reversing this fix so EAC, please look into this and see if you can set some sort of exemption.

 

This is the page that linked the fix that I used. http://forums.cdprojektred.com/forum/en/the-witcher-series/the-witcher-3-wild-hunt/tech-support/37952-fix-force-surround-audio-if-your-w3-stuck-in-stereo-this-makes-it-surround

Edited by ZachTheGunner

Share this post


Link to post
Share on other sites

Hi everyone,

 

We've pushed now to live an anti-cheat update that should hopefully help with some of these errors. We're also checking the Ribbon Disabler now to see if we can whitelist it in these checks.

 

Could you see if you're able to run Squad now without errors? If you'd still get an error, please let us know and if possible could you add me in Steam Friends: http://steamcommunity.com/profiles/76561197999579793. Thanks!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×