Jump to content
Underwater Bimbo

D3D device lost error on better CPU?

Recommended Posts

Hey fellow squadlings,

 

I recently started getting a strange error. It started happening after I upgraded my CPU from i5 to i7, and both before and after updating the drivers on the new CPU. 

whats strange is that on my old CPU, the i5, I would never crash, and would play for hours at a time, whereas now, on the i7, I seldom get more than 5 minutes of gameplay before my game crashes. While it does crash every 5 minutes or so, it does also run more smoothly in that short time. That is, it runs at a higher framerate and enables higher graphical settings. Anyone know of any workarounds? I just want to iterate that the crash bug occurred both before and after I updated my drivers, and also that my video card is a GTX 550 Ti. My RAM card is 8GB 

 

I'll paste the error message below: 

 

error 
file:d\g\pipelines\owi-squadrelease-a-8\U\Engine\Source\Runtime\windows\D3D11RHl\Private\D3D11Util.cpp][Line:176] 
Unreal engine is exiting due to D3D device being lost. (Error: 0x887A0007 - 'RESET')

Share this post


Link to post
Share on other sites

When you upgraded from the i5 to the i7, did you change motherboards as well?

Share this post


Link to post
Share on other sites

Motherboard drivers are usually quite sensitive, and it is generally understood that if you upgrade your motherboard, it's best to reinstall your os from scratch.

That's not necessarily the problem, but it certainly could be.

Share this post


Link to post
Share on other sites

Go to GEFORCE and download the driver before the recent one. i think the new graphics driver are bugged, so just roll back a version

Share this post


Link to post
Share on other sites

Uninstall steam, go under %appdata% local in explorer, delete squad folder and UE4, redownload install. Check your power supply, you'd need minimum gold rating on a reputable brand (seasonic, superflower evgas, corsairs), then check your motherboard settings. Motherboard website, donwload the latest uefi/bios, upload it on a flash drive, update your settings. Load everything back to defaults, disable XMP, since you have a K CPU, make sure your power settings are all on the max, if you have an auto overclock function on your mobo, just use it. Then enable XMP.

 

I'm assuming that your BUS speed is pumping much more your GPU therefore D3D device disconnected is presumably only your graphics card that lost the connection to the monitor in the chain, could be motherboard to GPU.

 

Make sure you're running pcie 3.0 or 2.0 if unavailable on both slots, use pcie 2.0, disable C states and EIST which introduces variable voltage according to load.

 

Assuming you're running a non-overclocked CPU, you'd have to determine it's stable enough through a stress test using for example OC scanner or a graphics benchmark like 3D Mark. In the event it isn't stable, then check again the settings for a stable voltage if it's not done automatically. Check as well what temps you're running at with HWinfo, you'd need a proper cooler. When your CPU is deemed completely stable, a fresh reinstall of windows is recommended but not required.

 

Make sure you download the latest chipset even if it's the same off your motherboards website, high chance this the solution. Then make sure you have also everything else linked, usually Intel Management Engine.

 

Another strong possibility is that you would need to download the Intel Graphics driver related to your GPU because there's a high chance that ingame PhysX is procesed thru the CPU, which doesn't have a driver (iris graphics). Try setting PhysX in the nvidia control panel to your GPU instead of Auto.

 

Then afterwards, try changing the cable connecting your GPU to your screen to the newer certification on 1.4 even if you get 2.0 it's reverse compatible, 6ft or less.

 

If the issue still subsists, then under resolution try setting your color format to RGB limited before full, try full if you can, leave all the other settings on default except single display mode, don't use optimal power which causes issues, rather choose adaptive or max power, maximum frames 1.

 

Check your other games, yet Squad is particularly demanding in a good way, so there's also a strong possibility that the settings that you enabled overloaded the pipeline in terms of video memory and you're saturating the maximum amount of memory that you have esp. considering that you have 8gb of memory and winblows requires 4GB free to operate. So get a brand new set of 16gb mem sticks, again depending on your chipset either ddr3 or ddr4. Don't just add another stick of 8gb even from the same brand because you'd need a two pack for the best compatibility. In addition your RAM bandwidth may be limiting the pipeline to the GPU.

 

That's all, 1) reinstall chipset driver (even graphics, optional troubleshooting) 2) A set of new RAM sticks 3) Cooler? 4) Run a benchmark for a stability 5) power supply upgrade? 6) display cable (try displayport if your monitor supports it) 7) try a fresh install 8) get an SSD at 256g minimum, recommend samsung make sure your motherboard supports SATAIII at 6gigs (the HDD lagging behind could be the cause as well) 9) try capping your framerate using afterburner RTSS which is bundled 10) upgrade gpu or try a lower resolution to see if the issue persists, Just get the crash dump in the app data file and open a ticket on this forum to devs.

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×