Jump to content
Sign in to follow this  
Mateus

Can you already fix the AMD?

Recommended Posts

Mateus   

Hello,

on some maps, I can play normally, but on some others, I get random lag spikes like the map stuff is loading over and over agin. I get stable 45+- FPS, but the game just freezes randomly for like 1-10 seconds... It is so annoying.

 

I am running on AMD FX-6300.

Any comments about my CPU being bad are irrelevant, I can play 2016 games with stable 50FPS, just this game...

Share this post


Link to post
Share on other sites

Try out THIS, might help you.

1 hour ago, Mateus said:

Any comments about my CPU being bad are irrelevant, I can play 2016 games with stable 50FPS, just this game...

sry but it's not irrelevant, i swap this year from an AMD System which was like yours running most games well, but Squad and ArmA3(moded MP, vanilla was fine) run's bad.

 

-Offtopic-

I switched over to Intel.... very noticeable diffrence in Games, power consumption and Temps.

I'm sure i'm saving the extra charge of the CPU, in 2 Years out of the electricity calculation.

Share this post


Link to post
Share on other sites
Mateus   

I run Arma very well.

 

Just this game... When the map is larger, it seriously looks like it loads it agin and agin, like it was software related, not hardware.

Share this post


Link to post
Share on other sites
Disco   

Actually, your problem may not be related to map loading... It could be sound bug that was present few versions earlier for AMD FX cpus. It's not on Devs side to resolve it but unreal engine 4's developers (some cooperation happend but issue was not simple to solve and needed UE4 audio redesign... not sure what is current status on that matter). Do you get stutter while someone use voip or too many sound happens? Try setting your audio to low instead epic in options/audio. Try to search the forums to get more information. It was well discussed in past.

Share this post


Link to post
Share on other sites
19 minutes ago, Mateus said:

I run Arma very well.

 

Just this game... When the map is larger, it seriously looks like it loads it agin and agin, like it was software related, not hardware.

I was running arma well to when in Vanilla, but when it comes to a moded Server and it's Full and the action is going to be CQB then my old AMD-system suck's even with just 1500m view distance settings.

 

And yes it's may be software related to, its not well optimized....

 

After All when u think you won't play this Game because this Problem then get a Refund from Steam and try it out again in a half year or so..

Edited by Jaghammer

Share this post


Link to post
Share on other sites

The engine SQUAD runs on is not very well optimised for AMD CPU's.

Yes some performance improvements have been made recently with v8 but it has a long way to go.

The only real world fix to play SQUAD satisfyingly is to dump your AMD computer and buy an Intel one.

As for your shuttering you can try minimising that by using an SSD hard drive and a high end graphic card, however they dont really fix the AMD problem and instead just make things a little bit smoother. Disk cleanup, up to date drivers, up to date windows updates and defragging can also help improve you playability and minimise ingame shudders.

Share this post


Link to post
Share on other sites
lisasu   
5 hours ago, Mateus said:

Any comments about my CPU being bad are irrelevant, I can play 2016 games with stable 50FPS, just this game...

more like "people with 6 years old low-end hardware are irrelevant"

 

you can't fight it forever, it's been too long already.

squad is not any 2016 game, what it has to offer comes with a price, and squad is at the limit now, any extra fps squeezed will be eaten by higher player count.

 

Share this post


Link to post
Share on other sites
Mateus   
5 hours ago, lisasu said:

more like "people with 6 years old low-end hardware are irrelevant"

 

you can't fight it forever, it's been too long already.

squad is not any 2016 game, what it has to offer comes with a price, and squad is at the limit now, any extra fps squeezed will be eaten by higher player count.

 

Not sure if u can read, but I run Squad at 50FPS stable, but bigger maps couse random freezing and it looks like all the textures are being loaded agin.

Share this post


Link to post
Share on other sites
Mateus   

FIX THE DAMN BUG GUYS, I AM FITTING THE RECOMMENDED HW performance. I did not pay 25€ for a broken game, cmon ffs.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×