Sign in to follow this  
Followers 0
reaperco12

Very long loading time

When I first played this game the loading time for the game was almost instant now it takes about 5 mins for the game to load from clicking on the steam icon to when I can actualy select a server it just loads the squad logo on my desktop and as I say takes about 5 mins to load the game no other issues with fps while in game only the fatal crash now and again like everyone else dose anyone have any ideas? thanks.

Share this post


Link to post
Share on other sites

Are you using a HDD? Loading times have stayed fairly consistent on a SSD. Longer loading times are to be expected as the game gets larger in size until that process can be optimized.

Share this post


Link to post
Share on other sites

The first time you launch after an update it takes awhile. But after that it opens fairly quick, even on HDD.

Share this post


Link to post
Share on other sites

I don't know what you call fairly quick but my game takes 2min28s to load.

Win 8.1 on  SSD and game on HDD (Western Digital blue 1To)

 

Anyway 1-2 min of loading time with a HDD is pretty common for Squad.

On a SSD you could expect 30s.

Share this post


Link to post
Share on other sites

Yes its a HDD and it loaded pretty quick when I first got it but now it takes like 5 mins just to get off the squad logo I will time it to tell you exactly

Share this post


Link to post
Share on other sites

3.29 to load the game and another 3 mins to get into a server

specs 1tb hdd

128SSD

970 GTX

I746OOK I THINK LOL

16GB RAM

Not a major issue but I play with ppl with similar specs and there in on a server with in about a min often I miss out on join squad due to the long wait any one any ideas?

Share this post


Link to post
Share on other sites

Not sure if it still works but clear/delete the log files.  Next time might still be slow but after that it sped back up.

 

C:\Users\[username]\AppData\Local\Squad\Saved\Logs

 

Other thing I noticed is that once you start the game you shouldn't click anything else until it loads.  Seems that if I click away it will take 10x longer to load.

 

The whole getting into a server part will hopefully be upgraded on one of their near future releases... as that browser drives me nuts too.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0