Jump to content
Chuc

Release: Alpha Version 7.7

Recommended Posts

Anyone getting a lot of disconnects and server closing message? Since the update, the main problem is getting the server is closing message or my game crashes at the end of matches due to a fatal error. For me, it seems like it's taking more time in changing maps or transition of end of game to a new game. I get a black screen that seems to last a few minutes and then poof, it's the next map or I get a flickering loading screen back to the main menu with a server closed message.

Edited by Ghost Assassin

Share this post


Link to post
Share on other sites

Hello Squad Dev Team,

 

first of all a huge thanks for the V7 release :) . Yesterday I updated my local ded. server and some buddies an me were checking out what's all new in this big package. The server ran stable for hours (well...max. 5 players on it) and we had a lot of fun with the vehicles (some funny stunt action..see here: http://steamcommunity.com/profiles/76561197968067439/screenshots/?appid=393380&sort=newestfirst&browsefilter=myfiles&view=imagewall ).

Driving a truck in Squad almost feels like you drive a truck in "Spintires"...guys...honestly...I never expected such a awesome physics behaviour in the first release of vehicles!! How the suspension works when you drive offroad, the acceleration, the engine sound..and and and...I'm really impressed!! Thank you guys :) !!

 

About the problems on high populated servers with lags and crashes etc.: you will find a way to fix this...I know it!

 

@IrOnTaXi: I guess it was you who wrote on reddit, that such errors never occured during the last tests on high populated servers before release. As I was updating my dedicated server on my gaming PC (server and client where running on same machine), I noticed a error message after steamcmd update (I'm using a batch-file ... so the console disappeared to fast to see which error discription it was). We played then for about 3-4 hours without any problems. Then we decided to stop the server to adapt some teamswitch parameters in Server.cfg. I stopped both - client and server...quited steam...restarted the server. After server was up and I started the steam client, the server crashed. After some retries I decided to updated the dedicated server on my laptop. It worked, but also with an error message in console at the end.

Maybe the steamcmd server deployment was faulty yesterday? Just a guess...

 

Respects, 

El Duderino

Share this post


Link to post
Share on other sites
4 minutes ago, Ghost Assassin said:

Anyone getting a lot of disconnects and server closing message? Since the update, the main problem is getting the server is closing message or my game crashes at the end of matches due to a fatal error. For me, it seems like it's taking more time in changing maps or transition of end of game to a new game. I get a black screen that seems to last a few minutes and then poof, it's the next map or I get a flickering loading screen back to the main menu with a server closed message.

 

same here. today i cant even join any server. the reason is always sth. like "connection to host failed" or without any notification.

Share this post


Link to post
Share on other sites
2 minutes ago, polehu said:

 

same here. today i cant even join any server. the reason is always sth. like "connection to host failed" or without any notification.

 

Me 2...

Share this post


Link to post
Share on other sites

lots of great content,  you done a good job on it!.

 

animation of running, going sideways, up hills etc is a bit different but i  like that

 

i have had a drop in FPS, which i dont like lol..  game has bugs i have noticed where i had no give up option, was laying there unable to do anything so had to suicide, constantly getting fatal error at the end of rounds, have to rejoin

 

cant wait for a patch to fix the faults and give us more fps back :D other then that awesome job

Share this post


Link to post
Share on other sites

Hmm...today i've noticed two strange things.

 

1) Now i'm experiencing the problem with connection to servers - frequently, it's ending up by a black screen(without ability to return to Main Menu) or "Connection has been lost" message.
2) I've noticed that utilization of my CPU by SQUAD has dropped from 40-55% to 15-25%. So, we really have some optimization issue, which is a good thing, actually, coz it's not like the game became more demanding to PC-specs, and thus, it may be solved by the devs - to bring performance to the level prior to V7.

Share this post


Link to post
Share on other sites

Performance has halved for me. I used to have a nice 40 fps on a 50 player server, now I'm lucky to get 20 fps.

 

System:

Amd fx 6300

Gtx 750 ti

8Gb ram

 

Share this post


Link to post
Share on other sites

I believe server owners need to step up their game and reconsider their providers.

 

From what I noticed there are servers that crash constantly and ones that can go on for hours without a hickup. There are 60ppl servers that have no vehicle rubber-banding on vehicles at all! Had a couple of rounds on the weekend and the game really shines when not held back by the server.

 

Obviously we're dealing with a lot of bugs here - some client, some server side - that will be ironed out in due course. However, Squad will always be a server resource-intensive game and as such will require a strong server to run it.

 

I'd like to urge all established servers to reassess their providers and ensure that they chose the best specced server there is available within their budget.

 

Separately from that...

 

Great update. I must be lucky as i have not noticed a significant performance drops and I had a very enjoyable Sunday (thanks Devs for releasing on Sunday morning!). Of course there are bugs but the fun-factor was more than enough to compensate. My favourite feature is the vehicle suspension system - it looks very realistic.

 

With introduction of the vehicles, the PR nostalgia hits home hard! (all I need now is a desert map). I finally feel at home.

 

To me it's the most important milestone. The gameplay has changed diametrically. Infantry tactics have changed. FOB placements have changed. Defensive plans have changed. It's fantastic to see players adapt to the new circumstances and SLs having to adjust their established strategies. Also, the introduction of vehicles will allow the dev team to observe how the gameplay progresses and identify and quash potential abuses or gross imbalance.

 

Looking forward to V8! :)

 

 

Share this post


Link to post
Share on other sites

Best work a Dev Team has done in a long time.  

 

Drove around with a Humvee and made Patroul on Kohat valley. Meanwhile building a Checkpoint FOB to resupply and repair the humvees. 

 

The Performance Problem is kinda sad though. 

For one part the rubberbanding and vehicle lag on most servers is really horrible. On the other hand it was kinda expected for me to have frame drops in that version. 

Lots of crashes and some minor bugs with the vehicles. 

 

But i trust in the guys to get out a Hotfix to bring it into a more stable State. 

 

Love you :-D

 

Share this post


Link to post
Share on other sites

Bug Report

 

you cant turn left when using a Stick movement on vehicles. please fix this as a steam controller uses not having this really hurts.

Share this post


Link to post
Share on other sites
Hmm...today i've noticed two strange things.

 

1) Now i'm experiencing the problem with connection to servers - frequently, it's ending up by a black screen(without ability to return to Main Menu) or "Connection has been lost" message.

For this one, hit your tilde key (~) and type "disconnect" and you should be able to return to the main screen

Share this post


Link to post
Share on other sites
18 hours ago, Polo Besscobar said:

 

Great work, guys! It needs polishing, for sure, but we can only congratulate the dev team for releasing such a heavy update with so little mistakes. From my experience, having shorter release cycles works better, but then again ... I've never done any multiplayer game development, so I don't really know.

 

Maybe I've missed it since I didn't read through the whole thread, but is there any way to report bugs / comments / suggestions targeted strictly as to what has changed between the last and this update? I believe there are a couple of things that are pretty annoying but could be solved with a small patch in the next week or two...

 

Regarding the FPS drop .... I've also experienced it. This is my rig and yesterday's performance (before the update): http://forums.joinsquad.com/topic/22478-benchmarks-with-screenshots-and-fps-counter/

 

 

Today, after the update, I got a similar performance on a server with cca. 15-20 players, but on a full server with cca. 65 players, I've experienced a 25-30 FPS drop. What seems unusual is the FPS drop was "permanent" and didn't depend on my current field of view (what was being rendered on the screen). It just dropped from 50 to 25, making the game basically unplayable. Lowering the resolution didn't really help that much (it maybe added 5 FPS).

 

I did some tweaking in my NVidia Control Panel settings and changed the Image settings from "Best quality" to "Let the application decide" (application controlled). And it helped! My performance is back to 40-60 FPS, so my suggestion to all who've experienced performance drop is to look into graphic card's driver settings (on a global level) and start from there, then proceed to tweaking Squad's graphic settings. The same rule of thumb stil applies: you'll get half the FPS on a full server compared to what you get on the Firing range.

Correct, you should always use the setting  "Let the application decide"  its even better anyway than the "Best quality" setting in panel.

Share this post


Link to post
Share on other sites

I reckon people with problems should look into this, the latest windows 10 aniversary update had made some steam games run badly, like loosing all there fps, it is a bug, turn off gamedvr in xbox app and try again.

Share this post


Link to post
Share on other sites
6 hours ago, Ghost Assassin said:

Anyone getting a lot of disconnects and server closing message? Since the update, the main problem is getting the server is closing message or my game crashes at the end of matches due to a fatal error. For me, it seems like it's taking more time in changing maps or transition of end of game to a new game. I get a black screen that seems to last a few minutes and then poof, it's the next map or I get a flickering loading screen back to the main menu with a server closed message.

patience ...it is expected ...overall for alpha0.7 they are doing wonderful job.... i had issue...i lost crazy fps...yet i was looking precisely for what was added and how was it implemented...and there is a hot hot fix coming in : ) no doubt

Share this post


Link to post
Share on other sites

I also been having roughly 20 frames less then the previous build. I also have a difficult time getting into servers that are near capacity...any idea when a hotfix while be making its way through? i am dying to play!!

Share this post


Link to post
Share on other sites

We are pushing a hotfix (the version will stay as 7.0) which fixes a number of server side crashes that have been occurring with the launch version.

 

Enjoy!

Share this post


Link to post
Share on other sites
35 minutes ago, Merlin said:

We are pushing a hotfix (the version will stay as 7.0) which fixes a number of server side crashes that have been occurring with the launch version.

 

Enjoy!

I literally just got a fatal error minutes ago.. pls work :(

Share this post


Link to post
Share on other sites
41 minutes ago, Merlin said:

We are pushing a hotfix (the version will stay as 7.0) which fixes a number of server side crashes that have been occurring with the launch version.

 

Enjoy!

 

 

Thank you guys for the continued work!  Ground work laid out in v7 is great.  Look forward to continued development.

Share this post


Link to post
Share on other sites

not bad but we need fucking game which will have good frames and actualy be playable, years will pass and you wont make it playable for amd users!!! shame on you.

Share this post


Link to post
Share on other sites
5 minutes ago, losmi87 said:

not bad but we need fucking game which will have good frames and actualy be playable, years will pass and you wont make it playable for amd users!!! shame on you.

 Well, I5 3450, gtx 660 ti, 12 gb of ram and ssd = lower then 20 fps in the center of yehorivka, 60 ppl server. This is after hot-fix. Befre hot-fix it was around 10

Edited by Intrane

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×