Jump to content
Chuc

Release: Alpha Version 7.7

Recommended Posts

Yesterday Norby requested on discord to fill up the OWI test server. He gave us the PW for the beta branch. Unfortunately the max. player count (what I have seen) was about 45 players. For a better test 72 players where needed. But the server emptied quickly after 1 hour.

 

It would be nice if more guys join the squad community discord server and join such full-server-load tests and give a constructive feedback after such a test session.

 

I recommend to restart your PCs after Squad updates. I had no issues while playing after the update - only after closing the game (had the same issue on 7.3 release but a PC restart fixed it). 

 

From my perspective the game runs smoother on some maps, on others (like Sumari) I have low fps from round start on. I played for about 2 - 3 hours with 3-4 map changes -> NO fatal error crashes and NO other crash during this time.

 

 

Share this post


Link to post
Share on other sites
2 hours ago, El Duderino said:

Yesterday Norby requested on discord to fill up the OWI test server. He gave us the PW for the beta branch. Unfortunately the max. player count (what I have seen) was about 45 players. For a better test 72 players where needed. But the server emptied quickly after 1 hour.

 

It would be nice if more guys join the squad community discord server and join such full-server-load tests and give a constructive feedback after such a test session.

-snip-

 

With all due respect to @Norby why couldn't he post the OWI V7.4 test session "Here"...This is the place,if you know what i mean!?. ;)

Ta much Dev's...

Share this post


Link to post
Share on other sites
42 minutes ago, Xx-RAGING-DEATH-xX said:

 

With all due respect to @Norby why couldn't he post the OWI V7.4 test session "Here"...This is the place,if you know what i mean!?. ;)

Ta much Dev's...

 

I guess it's because you get a system notification (default discord settings), if someone writes to "@everyone" and there are already some hundreds on the server and most people have discord in the background running (start with windows)...but these are all just guesses...

Share this post


Link to post
Share on other sites

no fatal error for 2 maps in a row so far, fps still in 40's for me...also i keep noticing when im one on one fire fight if the enemy gets a advantenge on me & shoot at me first i get like a half of a sec  freeze then boom im dead , i been having this problem since v7

Share this post


Link to post
Share on other sites

New version works fine here. And performance is (at least on OP First Light) back to the level of pre-A7. Thanks!

Share this post


Link to post
Share on other sites

My FPS are slightly better; definitely improved than v7.3!

 

I played two full rounds with different map for 2 hours and no single Fatal Error (so far)

 

 

Share this post


Link to post
Share on other sites

Lol. Idk how, but during a Squadsession, I was gunner on stat russian tripod, I had a bluescreen of death. Somehow on reboot he even couldn't find my system-ssd again. I had to go into bioas and changed it back (the boot order was changed). I it is less likely to blame Squad, but wired thinks happen out there today...

Share this post


Link to post
Share on other sites
55 minutes ago, Barbarossa said:

Lol. Idk how, but during a Squadsession, I was gunner on stat russian tripod, I had a bluescreen of death. Somehow on reboot he even couldn't find my system-ssd again. I had to go into bioas and changed it back (the boot order was changed). I it is less likely to blame Squad, but wired thinks happen out there today...

 

Wow O.oO.o If ever its due to Squad... O.o

Share this post


Link to post
Share on other sites

Nothings here for me guys...

I'm gonna go in hibernate state(for SQUAD game)until..DEVs finaly FIX SQUAD or I have to buy new RIG...

I'm dissapointed and sad.

Share this post


Link to post
Share on other sites
27 minutes ago, Dr.Quick said:

Nothings here for me guys...

I'm gonna go in hibernate state(for SQUAD game)until..DEVs finaly FIX SQUAD or I have to buy new RIG...

I'm dissapointed and sad.

Unfortunately you'll have to wait for them to fix Squad because the game runs like crap even on good hardware. 

 

Wish I could test 7.4 but I'm between video cards right now. 

Share this post


Link to post
Share on other sites
35 minutes ago, lawnboy said:

Unfortunately you'll have to wait for them to fix Squad because the game runs like crap even on good hardware. 

 

 I do now own i6700k and gtx1070 and its fine! I think 40-60 fps stabel is right on 72player server.

 

But what I really find interesting is, that I do have now a 8GB Ram videocard. On epic settings the how game needs 4,5-5,6GB video ram. Thats a lot of stuff. So I think the performancefixing will take lots of time and affort for the OWI guyes...

Share this post


Link to post
Share on other sites
2 hours ago, Dr.Quick said:

Nothings here for me guys...

I'm gonna go in hibernate state(for SQUAD game)until..DEVs finaly FIX SQUAD or I have to buy new RIG...

I'm dissapointed and sad.

 

What's your rig Quick ?

Share this post


Link to post
Share on other sites
9 hours ago, Barbarossa said:

 I do now own i6700k and gtx1070 and its fine! I think 40-60 fps stabel is right on 72player server.

 

But what I really find interesting is, that I do have now a 8GB Ram videocard. On epic settings the how game needs 4,5-5,6GB video ram. Thats a lot of stuff. So I think the performancefixing will take lots of time and affort for the OWI guyes...

I want you to think about what you're saying here, because 40-60 fps on a rig like that isn't "fine" it's downright piss poor.

 

If I spent $750 on a processor and video card I'd expect maxed out settings with a steady 60 fps as a bare MINIMUM, because those chips are MORE than capable of delivering it!

 

Seriously, that is some of the fastest kit on the market right now and if that's the best it can do in Squad just think of how bad it is for vast majority of gamers who don't have anywhere close to the amount of disposable income it takes to purchase stuff like that. 

 

Edited by lawnboy

Share this post


Link to post
Share on other sites

I have a good rig and it runs just fine. Not everyone is having this issue.

Sent from my SAMSUNG-SM-G920A using Tapatalk

Share this post


Link to post
Share on other sites
11 hours ago, Nightstalker21 said:

 

What's your rig Quick ?

Cpu...amd 960t 4 core

Gpu...hd 6950

 

Bf series run well around 45-55 fps

SQUAD was also playable until vehicles came on...i would go on smaller servers max 50 and enjoy with no lower then 30fps which I need for let's say normal gameplay.

Now I'm stuck with 8-18 fps...

I have no nerve enymore ...

 

Share this post


Link to post
Share on other sites
5 hours ago, lawnboy said:

I want you to think about what you're saying here, because 40-60 fps on a rig like that isn't "fine" it's downright piss poor.

 

If I spent $750 on a processor and video card I'd expect maxed out settings with a steady 60 fps as a bare MINIMUM, because those chips are MORE than capable of delivering it!

 

Seriously, that is some of the fastest kit on the market right now and if that's the best it can do in Squad just think of how bad it is for vast majority of gamers who don't have anywhere close to the amount of disposable income it takes to purchase stuff like that. 

 

 

I totally agree with you. Before I had an AMD Phenom X61100T. I had the 10fps. And it wasn't only Squad that made me change. After I tried lots of games, all were working much much better thatn on AMD. Seems like the hole gaming industrie is Intels bitch, bringing back money to the hussler.

 

Clear, 40fps isn't that what I exprect. But finally Squad is really playable. But I don't think thei will get it run much better soon. :(

Share this post


Link to post
Share on other sites
2 hours ago, Dr.Quick said:

Cpu...amd 960t 4 core

Gpu...hd 6950

 

Bf series run well around 45-55 fps

SQUAD was also playable until vehicles came on...i would go on smaller servers max 50 and enjoy with no lower then 30fps which I need for let's say normal gameplay.

Now I'm stuck with 8-18 fps...

I have no nerve enymore ...

 

 

I can understand your frustration, I'd feel the same if I were you !

Honestly, a lil update of your GPU would be a good choice I think (I'm not going to say anything about AMD CPU as you're certainly aware of the AMD+Squad debate) I personally have a R9 280X which is not very pricy nowadays and I very rarely go under 30 FPS, usually play @ 45-55-60 and 35-40 on crowded servers (72), 30 on crowded + most demanding maps ;) And I use a SwwetFX which makes me loose an average 1-5 FPS .

 

Did you use all tweaks Squad community gives us ? smo0ths ones and so on ?

 

Hold on man ;)

Share this post


Link to post
Share on other sites
9 minutes ago, Nightstalker21 said:

Looks like SweetFX no longer works with 7.4.

Actually trying to find a solution, still working on it as it really makes this game sharper.

 

It does work, i have reshade and sweetfx working with 7.4.

Share this post


Link to post
Share on other sites
4 minutes ago, Kalbouneh said:

 

It does work, i have reshade and sweetfx working with 7.4.

I get kicked by EAC since tonight, 1st time I play Squad 7.4 ; 7.3 worked fine. Tried uninstall-reinstall, verify game cache, uninstall-reinstall EAC and so on, doenst works atm.

Will keep trying ;) TY for the tip

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×