Jump to content

Recommended Posts

I just got squad and get 30 to 40 fps at most as well as experiencing drops down to 10-15 fps frequently. This makes the game very difficult to play. Anybody have ideas as to why this is happening? Note that this is also on medium and low graphics, my pc should be able to do much better than this on 1080p (Also thermal throttling is not an issue)

 

Any help is much appreciated. Thanks!

 

PC Specs:

Cpu:  FX9590 overclocked to 4.8ghz

Gpu: R9 390X

Ram: 16GB at 1866

Drive: Game is on a ssd (850 Evo)

Share this post


Link to post
Share on other sites

I have the exact problems as you!! Very frustrating. How often does it drop FPS? Is it constant or only on certain maps and or when combat gets heavy. 

Because i find that myself it only drops FPS on certain maps etc Gordok and those forestry maps.

 

Share this post


Link to post
Share on other sites

It is on all the maps i have played but only when i am in places with buildings or the more foresty maps. So yes i definitely experience the same as you.

Share this post


Link to post
Share on other sites

Hello and welcome to Squad @ackleyand @Joshua.d132,

 

first thing I would try:

  1. settings - audio - switch to low audio
  2. restart game

 

furthermore apply some ini tweaks:

Share this post


Link to post
Share on other sites

Thanks for the suggestion, I noticed a slight up in frame rate but the frame drops and stuttering were still very much so there. I will attach a video of my game play, maybe this will help troubleshooting.

 

Video: 

 

Share this post


Link to post
Share on other sites

Also note that during the range test seen above i was getting around 150fps, so it doesnt seem to be that im just getting low fps overall it just drops frames very often.

Edited by ackley

Share this post


Link to post
Share on other sites

Do you by chance have any Razer products?
outdated Razer drivers are causing the game to stutter and freeze.
users uninstalled them and updated to the newest official and it resolved the issue.

 

also:

  • set shadows to medium or low
  • set windows power settings on high

Share this post


Link to post
Share on other sites

Thank you for the suggestions, i will try those out and let you know what happens. Also i do not have any razer products.

Share this post


Link to post
Share on other sites

After trying them Im still having the frame drops seem in the video above. Not sure what it is, feels like ive tried everything. Its very disappointing that this is happening because i think it is a great game but the frame drops just make it very hard to enjoy. Thank you so much for your guys suggestions!

Share this post


Link to post
Share on other sites

trim SSD (is it set to AHCI?)

 

make sure all the power modes in you graphics options and system and security/power options are set to high performance

 

go into your bios and make sure your CPU is getting the right voltage and check out other things in there that could be changing stuff

 

check gpu clock/mem speed and make sure they are running the right speed

Share this post


Link to post
Share on other sites

Reinstalling windows seems to be the solution. The game is running with no drops or stutters. Knock on wood. Thank you all for your help!

Share this post


Link to post
Share on other sites
51 minutes ago, ackley said:

Reinstalling windows seems to be the solution.

thx for reporting back.
 

locking thread.

 

PS.: PM me in case you need it unlocked

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×