Jump to content
=DRK=Viper

High Quality Graphics Config/ Settings

Recommended Posts

Here are some of my settings to make Squad pop a little. If you're struggling with fps, dont use this. This is for the people who want Higher Quality.

 

Go to    C:\Program Files (x86)\Steam\steamapps\common\Squad\Squad\Config

Open Default Engine

Copy and paste this under [System Settings]

 

r.LightFunctionQuality=3  (Not sure this is working yet, maybe use 2 i'll look into it)
r.ShadowQuality=5
r.Shadow.CSM.MaxCascades=4
r.Shadow.MaxResolution= 4096 (higher is possible)
r.Shadow.RadiusThreshold=0.01
r.Shadow.DistanceScale=1
r.Shadow.CSM.TransitionScale=2
r.DistanceFieldShadowing=1
r.DistanceFieldAO=1
r.AllowLandscapeShadows=1
r.SSR.Quality=3
r.SSR.MaxRoughness=1
r.MaxAnisotropy=16
r.Streaming.Boost=4
r.DepthOfFieldQuality=2

r.RenderTargetPoolMin=400

 

Then go to [/Script/Engine.RendererSettings] and find r.TextureStreaming and change it to False

So change it to r.TextureStreaming=False

 

Go try it out, and give me feedback weather it made some differences. Note that im still experimenting with these settings

 

Add me on steam: Gamer tag is: Viper

or my username  : DRK_Viper

 

Cheers, Viper out :)

 

 

 

Edited by =DRK=Viper

Share this post


Link to post
Share on other sites

Could you do a before and after comparison with screenshots taken with HighResShot 2 command? Screenshots you take with this command go to this folder.

 

C:\Users\YOURUSERNAME\AppData\Local\Squad\Saved\Screenshots

Share this post


Link to post
Share on other sites

Tried out the settings, along with SweetFX, and the gfx seems to "pop" out more. It looks more smooth, although I might have taken approximately 3-5 hits on FPS  - perhaps more on certain maps and certain locations - so I'm experimenting a bit to find a good compromise. But I wondered, what exactly does disabling 'texturestreaming' do? Does it mean that all textures are pre-loaded, instead of rendered on the fly? Because load times seem to have increased slightly, often resulting in connection time outs. I've gotten a strange stutter as well, but that might be me playing around with the anisotropy settings and the SMAA.

Share this post


Link to post
Share on other sites

r.LightShaftQuality=5                      <--- only 1 works
r.Upscale.Quality=5                        <---- 3 is highest and 0 is better quality for some reason
r.DepthOfFieldQuality=5                  <---- 2 is highest
r.SSR.Quality=5                             <---- 3 is highest
r.SSR.MaxRoughness=0.9              <----- 1 is highest                
r.SceneColorFringeQuality=5           <------- 1 is highest
r.LightFunctionQuality=5                 <------- 3 is highest but i dont think its currently being used

 

If you want better than ultra this is all you can do right now

 

r.SSR.Quality=3
r.SSR.MaxRoughness=1

r.MaxAnisotropy=16

r.Streaming.Boost=2      <--- highest is 4

r.DepthOfFieldQuality=2 

 

Have fun

 

(i have a ultra+ config in my performance thread that will always be updated)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×