SuicidalChair

Squad Keeps Freezing discussion

27 posts in this topic

There have been numerous reports of people saying squad is freezing every couple of seconds or minutes to the point it is rendering the game unplayable. Today I had some luck with a user who contacted us via support.joinsquad.com

We have nailed it down (at least for this user, it may not apply to everyone but still a good number of you) to bad Razer software.
I first noticed this when I ran Process Monitor on the end user's system and seen this:

XfkJzmE.png

Which shows the Razer Game Scanner constantly scanning squad
Although this wasn't the root of the issue it was related.
After discussing with the user he responded with:
 

Quote

Hello! I have tried disabling Razer Game Scanner in the services, and that did not help. However, fully uninstalling both my razer drivers (Razer Synapse 2.0 and a separate Razer Lachesis driver) did the trick it seems, I tested it both in firing range mode and multiplayer. I still need to find a way around it because I need to have those drivers. I believe I had unlicenced copy of the drivers, I will install official one and report back in when I can.


So we have the cause and a "band-aid" of a resolve, but I am still looking into making sure your razer products still work as well as squad. I am leaving this thread open to discuss the situation and hopefully provide some feedback to users who reported the issue and haven't found a fix yet.

I will update this thread when I have more information.

ALSO worth note is that if you do not have any razer products / software then setting your audio quality to low has also resolved a similair issue with stuttering.

Share this post


Link to post
Share on other sites

I was also experiencing Squad freezing up for a few seconds every 30 seconds or so (it varied), but I don't use any Razer products.

 

Here's another possible fix for Windows 7:

 

Background: In task manager, with "Show processes from all users" ticked, svchost.exe would be using an entire core's worth of CPU upon playing Squad and even after closing Squad. Digging deeper, the culprit is wuauserv (Windows Update service). Ending the service or killing the process stopped the freezing for a few minutes. Turning off Windows Update didn't seem to fix it for me (and I can't recommend doing this permanently).

 

Solution: However! Installing KB3161608 seems to have fixed my freezing.

 

I needed to use the manual installer because Windows Update wouldn't function long enough to do its job. If you have trouble installing the update manually (i.e. forever "searching for updates" during the installer) you may need to kill svchost.exe and try again.

Share this post


Link to post
Share on other sites

I'm a Razer mouse user. I only started getting these lockups after the most recent update. --Sorry I cannot tell you which one that is. I noticed I downloaded an update for SQUAD yesterday or the day before. Since then the lockups have been occurring. Ill try disable Razer Game Scanner and get back to this thread.

Share this post


Link to post
Share on other sites

v7.1 Stuttering

 

I have had no previous issues with earlier versions.  Loving the game and the flow (50fps on high)

 

Unfortunately, as soon as I updated to version 7.1 I am now experiencing the stuttering so many others have had in v6

v7.0 played smoothly for me

 

I'm not sure if this is the correct thread, but I saw no other discussing stuttering with 7.1 (only v6)

 

i5 3570 

GTX 770

8gb ram

 

Thanks for your time and effort, really loving the direction the game is going with Vehicles and the new lighting is rAd!

Share this post


Link to post
Share on other sites
7 hours ago, Wayne Newton 12 said:

v7.1 Stuttering

 

I have had no previous issues with earlier versions.  Loving the game and the flow (50fps on high)

 

Unfortunately, as soon as I updated to version 7.1 I am now experiencing the stuttering so many others have had in v6

v7.0 played smoothly for me

 

I'm not sure if this is the correct thread, but I saw no other discussing stuttering with 7.1 (only v6)

 

i5 3570 

GTX 770

8gb ram

 

Thanks for your time and effort, really loving the direction the game is going with Vehicles and the new lighting is rAd!

 yeah the same as me, i also use razer products

Share this post


Link to post
Share on other sites

Stuttering is back for me, also, in v7.1.  V7.0 did not stutter.

 

I am getting 50+ fps on most maps with settings default (mostly High/Epic).

 

Again, I have Windows updates pending. I'll install those and report back.

 

i5 4670k

GTX 980 Ti

16 GB RAM

Squad on SSD

 

Razer Mouse user. Though I haven't got Razer software installed, only mouse drivers (obs).

 

 

Edited by Cheesy_LeScrub

Share this post


Link to post
Share on other sites

so guys i had that freezing issue as well

tried to install pending windows 7 updates but no luck except the last windows defender definition update

i hid the rest of the pending updates without installing

the freezing is gone i can play now no issues

Edited by JozoNalozil

Share this post


Link to post
Share on other sites

I played four full rounds without a single freeze tonight, things I changed--

 

  • Outstanding Windows updates installed (there were 5);
  • AppData/Squad folder deleted, game files verified;
  • Steam overlay disabled.

One, or all, of these things stopped the stuttering. However, deleting the AppData folder in isolation did not resolve the problem last night.


I hope that kinda narrows it down.

Edited by Cheesy_LeScrub

Share this post


Link to post
Share on other sites

I had freezes every time I turned on the game after about one minute or so, but after I updated my razor synapse , then closed the program, then started the game, lowered my graphics settings to low, and then joined a game for it to froze again. At this point I opened the windows task manager to see if I could find any patterns for about 5 minutes and the game went back to the main menu find a server screen then I went to a server and played without joining a squad and it worked...For about 15 minutes and then froze. Rejoined, started a new server like normal and play without hick up for three games, I joined a squad after the first round.

 

One thing I noticed since I had tried to troubleshoot this problem before is that when I had selected windowed mode in the options It wasn't going to a windowed mode, it was more of a full screen.  (I had windowed mode on during the above paragraphs process) Widowed mode was working today though. I hope this helps.

Share this post


Link to post
Share on other sites

Any news on this problem?

Had problems with the stuttering/freezing in earlier versions but it seemed to be fixed.

It's back for me since the 30. Sept. Update.

Sometimes just a few minor freezes, sometimes its unplayable with 5-10 Second freezes with a few Seconds of gameplay in between. Sumaari seems to be most affected as far as I can tell,

Tried Disabling Antivirus, Disabling Steam Overlay, Turning off Logitech Gaming Software, Installing Windows Updates, switching to low Audio Quality and so on.

 

One (crappy) workaround i found is giving squad Real-Time-Priority in the Task-Manager. While it does keep the game from completely freezing, it limits the freezing to sounds so i guess it might be Audio-Related.

 

 

Specs:

Intel i5 4570

16GB DDR3

3072MB Radeon R9 280 Dual X

Win 7 64bit

SSD with Squad: Samsung 840Evo 120GB

Share this post


Link to post
Share on other sites
47 minutes ago, IrOnTaXi said:

Hey Guys.. anyone had any luck solving these issues? 

 

I got this issue with every version from V6 to V7. V8 has been running perfectly.

 

No matter what troubleshooting I undertook for the freezing prior to that, the common denominator seemed to be updating Windows. Each time the game was freezing I had outstanding Windows updates. And each time they were installed, the freezing stopped.

 

I only ever completed these three steps-- although listed first, the Windows update was the last thing I did.

 

On 8/11/2016 at 10:05 PM, Cheesy_LeScrub said:

I played four full rounds without a single freeze tonight, things I changed--

  • Outstanding Windows updates installed (there were 5);
  • AppData/Squad folder deleted, game files verified;
  • Steam overlay disabled.

One, or all, of these things stopped the stuttering. However, deleting the AppData folder in isolation did not resolve the problem last night.


I hope that kinda narrows it down.

 

I know absolutely squat about QA or game development or computers in general (aside from putting them together). So if you can rule this out immediately I understand haha. This is my personal experience.

 

i5-4670k

GTX980Ti

16GB Ram

SSD

Win7 64 bit

Razer mouse user

Edited by Cheesy_LeScrub

Share this post


Link to post
Share on other sites

Hi, i got this game on sunday! Havent been able to play it so much because it keeps freezing in the start up! i gett all the way to where the keyboard instructions are!
Last time i had to unistal the game, then it worked! and i changed the volume settings in the game yesterday! and today it wont start again!
the only way to get out of the freeze is to restart the computer!
I am not a tech guy so dont know any specs! but i Have a ASUS ROG GL552VW 
prossessor Intel(R) core(TM) i7-6700HQ CPU @ 260GHz 2.59GHz

really like to get this problem fixed, hopefully with a step by step :P

Share this post


Link to post
Share on other sites
On 7.11.2016 at 7:26 AM, IrOnTaXi said:

Hey Guys.. anyone had any luck solving these issues? 

 

Issue is gone for me.

Not sure if it is because of one of the Updates or because I use a different Audio-Output now.

Gonna swap back to the old Audio next time I play and see how that turns out.

 

Update: Tried it with the old Audio-device and had no issues so far so i guess you fixed it in my case.

Edited by Ollersplasher

Share this post


Link to post
Share on other sites

I'm also having issues with (sometimes extreme) stuttering making it impossible to play Squad when it happens. I have a good PC (play Arma 3 etc), Core i5, 8GB ram, HD7870XT, Win 7 64-bit. Tried the appfolder deletion and verifying integrity/steam game files. No luck so far. Don't have any Razor product. Not sure what to do now.

 

I also always get this error when starting Squad

 

GuO5zAb.png

Share this post


Link to post
Share on other sites

Having what I believe is the same issue. Stuttering to the point it feels like CS back on dialup days.

Win 7 64Bit
AMD FX 6350

Sapphire Radeon TOXIC R9 270X

8GB RAM

SSD

Non Razor User

Share this post


Link to post
Share on other sites

I had this problem where the game seemed unable to play at a point with all the freeze lag. I had to disable the surround sound on my headset to default sound and then it worked perfectly. If you experience strange freezing lag, try this. But then again, you probably want to play with the surround sound but I don't know how to do it without getting awful lag....... (I'm using the spectrum wireless logitech headset btw).

Share this post


Link to post
Share on other sites

One thing I've noticed is that off-screen events are still "rendered" Every explosion on a map regardless of distances causes me to freeze or lose a few frames. It's why I get 60 fps on a server with 2 or 3 players and it drops as more sign on. I hope OWI can find a way to just cull anything not rendered/relevant in a meaningful way. If I can hear it cool, doesn't mean it needs to go through ALL the steps to be recreated since I can't see it anyway.

Share this post


Link to post
Share on other sites

Game played perfectly fine, up until last Wednesday (Feb 08 2017) when I installed the latest NVidia drivers. Been stuttering ever since.

Rolled back to my previous drivers. No change.

Reinstalled the game. No change.

I don't own any Razer products, or believe to have any Razer drivers running on my computer.

 

Stuttering happens when there are audio events (gunshots, explosions, VOIP talking). Never had any issue before. Now the game is unplayable.

 

Edited by Xmaster

Share this post


Link to post
Share on other sites
Specs: 
AMD 9590 CPU 
ASRock 990FX Extreme9 MoBo 
EVGA 970 FTW Edition  GPU 
240GB PNY SSD 
1TB Toshiba HDD 
32 GB RAM 
750 Gold+ PSU 
 
Basically can play for 5-10 minutes and the entire pc just freezes and have to 
reset the system, can't ctrl/alt/del or anything.  Start happening since the 9.0 
patch.  I was using a Razer mouse but switched to a generic and removed all 
razer software as that's a known issue.  I can run any other game just fine, 
Ghost Recon Wildlands, etc, but Squad is truly unplayable at this point.  

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now