Jump to content

Recommended Posts

Hello guys.

I have a server of squad.

The server when it exceeds 35-40 players start to lag.

Is really impossibile to play.

I controlled instantly the server.

And the server was using only :

0.5 % of CPU

5 % of RAM

2 mbps/s of bandwidth.

 

I did a SPEED TEST.

And the server do 720 mbps/s to download and 540 mbps/s to upload.

For this i dont understand where is the problem.

My Server is powerful but lag.

 

HARDWARE:

1 GB of bandwidth

CPU I7 6700 K

RAM 32 GB DDR4 2133 MHZ

Windows Server 2012 R2

 

Help me PLEASE.

Edited by Master-Antonio

Share this post


Link to post
Share on other sites

Well there's a few things you could try.

 

Edit Squad\Config\DefaultEngine.ini, search for the line NetServerMaxTickRate and change the default value (50) for something around 10 or 15.

NetServerMaxTickRate=10

 

In Windows, make sure your CPU is running in High Performance.

 

Control Panel > System and Security > Power Options > High Performance.

Share this post


Link to post
Share on other sites
38 minutes ago, ibk said:

Well there's a few things you could try.

 

Edit Squad\Config\DefaultEngine.ini, search for the line NetServerMaxTickRate and change the default value (50) for something around 10 or 15.


NetServerMaxTickRate=10

 

In Windows, make sure your CPU is running in High Performance.

 

Control Panel > System and Security > Power Options > High Performance.

 

I setted 

NetServerMaxTickRate=12
LanServerMaxTickRate=12

MaxInternetClientRate=70000

 

But i need now a stress test, i need 40 players in the same time, to see if the problem is solved.

Share this post


Link to post
Share on other sites

Set your NetServerMaxTickRate to something like 35.  With your specs, it should be easy.

Share this post


Link to post
Share on other sites
6 hours ago, Soulzz said:

Set your NetServerMaxTickRate to something like 35.  With your specs, it should be easy.

Also the LanServerMaxTickRate?

 

MaxInternetClientRate=70000 is good? is right?

Edited by Master-Antonio

Share this post


Link to post
Share on other sites

Ignore LanServerMaxTickRate, that's if you are doing a local match.

 

MaxInternetClientRate should be fine.

Share this post


Link to post
Share on other sites

Did you get your problems sorted @Master-Antonio ??

 

I'm looking for a server and wanted to know the specs I need.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×