SuicidalChair

Confirmed fix for Crashing while using Server Browser

https://forum-en.msi.com/index.php?topic=178063.0

TL;DR
MSI motherboards especially, but others as well may come with pre-installed net killer software that trys to manage your network card, its the Devil, remove it as discussed in the link above.

(Its the same fix for 0 servers showing up in your server browser, just a different issue caused by it, Thnx Litoralis)



This has also worked for a few members who do not have any MSI killer network software: 
 

Quote

in Steam -> Settings -> In Game options there is a dropdown box for "In-Game Server browser: Max Pings/minute if you turn that down to 500, you will get servers reliably

 

Share this post


Link to post
Share on other sites

Yeah that's what happens when corporations think they know everything better than the user :/

Thanks for the heads up

Share this post


Link to post
Share on other sites

This is interesting;I have MSI, and the killer software and have had no problems. I'm thinking I'll just leave it alone and remove it if I start having problems.

Share this post


Link to post
Share on other sites

I haven't got a MSI Motherboard but the same problem. What do I do?

Maybe it helps, if you update your network driver. No matter what mb you have, it should be up to date . Newest bios etc.

Share this post


Link to post
Share on other sites

MSI MB here.

I had some issues with the server browser finding 0 servers and every once in a while crashing back to the desktop. 
However, I changed the batch size of the pinged servers via Steam (Settings -> In-Game -> In game server browsers ... ) to something less. Currently I have it at 500. Takes a bit longer to list the servers, but it works w/o crashing.

Perhaps that might help.

Share this post


Link to post
Share on other sites

I am currently investigating if anti virus can cause the same symptoms as well, pretty much anything that trys to control your network card is a suspect right now.

Share this post


Link to post
Share on other sites
On 6/27/2016 at 7:44 AM, Scum said:

MSI MB here.

I had some issues with the server browser finding 0 servers and every once in a while crashing back to the desktop. 
However, I changed the batch size of the pinged servers via Steam (Settings -> In-Game -> In game server browsers ... ) to something less. Currently I have it at 500. Takes a bit longer to list the servers, but it works w/o crashing.

Perhaps that might help.

yes this is another confirmed fix people are reporting, thanks for the feedback!

Share this post


Link to post
Share on other sites

So i am not sure if this will help. had originally had the problem no servers showing. I tried the fix above where you go into steam.

On 6/21/2016 at 8:04 AM, SuicidalChair said:

in Steam -> Settings -> In Game options there is a dropdown box for "In-Game Server browser: Max Pings/minute if you turn that down to 500, you will get servers reliably

this worked for me i have servers now.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now