Jump to content
KanZik

Squad will not launch

Recommended Posts

Okay, i tried every basic things, so just stop talking about downloading C++, and update drivers etc. I know you guys are trying to help, but i can tell you that aint the problem. 

 

Thats the only that shows, when i press "Play", and then the "Loading..." is done, nothing happens. Does anyone know this issue?

f3b0f7ba3c6f3c7bdf20834b1fc51b35.png

 

Share this post


Link to post
Share on other sites
5 minutes ago, bilsantu said:

Looks like an EAC problem to me. Did you try reinstalling it?

Yup, 3 times....

Share this post


Link to post
Share on other sites

I know you must be angry, but naming your thread appropriately would give you higher chance of finding help. Just saying.

Share this post


Link to post
Share on other sites
30 minutes ago, MultiSquid said:

I know you must be angry, but naming your thread appropriately would give you higher chance of finding help. Just saying.

 

Yes, appropriate naming of the thread will probably help you to find a solution to your problem quicker, as well as to get people to take your thread more seriously.

 

Now, have you checked your Squad logs and/or your windows event logs to see what is going on? It seems to me like something is blocking the program. Possibly your antivirus? Have you checked that? @KanZik

Share this post


Link to post
Share on other sites

Edited topic title; Caps lock cruise control isn't permitted for Thread titles.

Share this post


Link to post
Share on other sites

can you please tell us everything you have tried so we don't have to waste our time writing out a list for you to try when you've done half of it?

Share this post


Link to post
Share on other sites
18 minutes ago, SuicidalChair said:

can you please tell us everything you have tried so we don't have to waste our time writing out a list for you to try when you've done half of it?

 

Would definitely be helpful. You said:
 

2 hours ago, KanZik said:

Okay, i tried every basic things...

 

But that doesn't really tell us much. I assume by the post that you have updated the drivers. But what else have you tried. Per my previous post, have you checked your logs and/or your antivirus?

Share this post


Link to post
Share on other sites
22 minutes ago, SuicidalChair said:

can you please tell us everything you have tried so we don't have to waste our time writing out a list for you to try when you've done half of it?

OKay list:

1. Uninstall game 5 times. 

2. Turn of anticheat plus deleted alot of programs.

3. Restarted my computer ike 10 times.

4. Installed C++

5. Installed latest drivers, of everything. 

6. Also tryed to install squad on my SSD.

7. I dont know how to run it as Administratot, when it's running through steam...?

Share this post


Link to post
Share on other sites
1 minute ago, KanZik said:

OKay list:

1. Uninstall game 5 times. 

2. Turn of anticheat plus deleted alot of programs.

3. Restarted my computer ike 10 times.

4. Installed C++

5. Installed latest drivers, of everything. 

6. Also tryed to install squad on my SSD.

7. I dont know how to run it as Administratot, when it's running through steam...?

you said above you re-installed anticheat so I'll take your word for it,

To run as administrator close steam out entirely (right click the steam icon in your system tray and click close) then right click your steam icon on your desktop and click "Run as Administrator"

Have you run all possible windows updates? even the optional ones? (after installing updates and rebooting you will have to search for more updates again)

What are your system specs?
Hardware, version of windows etc.

Did squad used to work before (is this a new problem?) or has squad never worked?

Share this post


Link to post
Share on other sites
3 minutes ago, SuicidalChair said:

you said above you re-installed anticheat so I'll take your word for it,

To run as administrator close steam out entirely (right click the steam icon in your system tray and click close) then right click your steam icon on your desktop and click "Run as Administrator"

Have you run all possible windows updates? even the optional ones? (after installing updates and rebooting you will have to search for more updates again)

What are your system specs?
Hardware, version of windows etc.

Did squad used to work before (is this a new problem?) or has squad never worked?

Yup game used to work, got 24 hours, plus before it came on steam!

 

I don't actually know the place for update, it just siad, no update avaible.

 

Specs:

b6477a66a6841b71c9cf2636c3e8c01b.png

 

Share this post


Link to post
Share on other sites

and you did reinstall easy anti cheat?
Which the installer is located here(By default depending where you installed it): 
C:\Program Files (x86)\Steam\steamapps\common\Squad\EasyAntiCheat

you can find it by opening steam and right clicking squad and going to properties, then local files, then browse local files...
Then go into the EasyAntiCheat folder and run the EasyAntiCheat_Setup installer.

Share this post


Link to post
Share on other sites
2 minutes ago, SuicidalChair said:

and you did reinstall easy anti cheat?
Which the installer is located here(By default depending where you installed it): 
C:\Program Files (x86)\Steam\steamapps\common\Squad\EasyAntiCheat

you can find it by opening steam and right clicking squad and going to properties, then local files, then browse local files...
Then go into the EasyAntiCheat folder and run the EasyAntiCheat_Setup installer.

Yes, still dosen't work. I just tryed.

Share this post


Link to post
Share on other sites

ok try this:

Try to launch squad, let it fail.
open start menu
type event viewer (although yours looks like its German so i have no idea if this works)
launch event viewer
expand "Windows Logs"
then click on "Applications"

look for any errors related to trying to launch squad.
report them here.
 

Share this post


Link to post
Share on other sites
20 minutes ago, SuicidalChair said:

ok try this:

Try to launch squad, let it fail.
open start menu
type event viewer (although yours looks like its German so i have no idea if this works)
launch event viewer
expand "Windows Logs"
then click on "Applications"

look for any errors related to trying to launch squad.
report them here.
 

3036d352c0e4c96bbfb3528352a91d4e.png

Share this post


Link to post
Share on other sites

so hard to troubleshoot something in German,
can you upload the contents in the log file shown above?
in C:\Users\Kanzi\AppData\Local\Squad\Saved\Logs\Squad.log 
(open with note pad)
 

Share this post


Link to post
Share on other sites
1 hour ago, SuicidalChair said:

you said above you re-installed anticheat so I'll take your word for it,

To run as administrator close steam out entirely (right click the steam icon in your system tray and click close) then right click your steam icon on your desktop and click "Run as Administrator"

Have you run all possible windows updates? even the optional ones? (after installing updates and rebooting you will have to search for more updates again)

What are your system specs?
Hardware, version of windows etc.

Did squad used to work before (is this a new problem?) or has squad never worked?

 

dont know if running steam as Administrator runs the game as Administrator also.

 

for me this fixed my problems with launching.

 

go to  

C:\Program Files (x86)\Steam\steamapps\common\Squad 

right click on the Squad.exe

go to properties

click on the Compatibility tab and check the Run this Program as an Administrator box

then hit apply

 

now every time i launch the game it prompts me to allow EAC to run and i click yes.

Share this post


Link to post
Share on other sites
1 minute ago, Snagg27 said:

 

dont know if running steam as Administrator runs the game as Administrator also.

 

for me this fixed my problems with launching.

 

go to  

C:\Program Files (x86)\Steam\steamapps\common\Squad 

right click on the Squad.exe

go to properties

click on the Compatibility tab and check the Run this Program as an Administrator box

then hit apply

 

now every time i launch the game it prompts me to allow EAC to run and i click yes.

I tried, dosen't work. And yea it's Danish :)

Share this post


Link to post
Share on other sites
1 hour ago, SuicidalChair said:

so hard to troubleshoot something in German,
can you upload the contents in the log file shown above?
in C:\Users\Kanzi\AppData\Local\Squad\Saved\Logs\Squad.log 
(open with note pad)
 

YO, currently on my mac, because im at a friend, can it ype private to you? 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×