Jump to content
Sign in to follow this  
Lucifer_USMC

My System specs and frame rate

Recommended Posts

I've got an i7 2600k 3.40 GHZ, 8 GB of Ram and AMD radeon HD7850 1 GBs. All the graphic settings are on low i just got post proccesing on high and playing with 1920x1080 resolution I am barely getting 30-45 frames in full server, What's wrong with my system specs ?  Is it not covering the medium specs of the game ? Or is it just from the optimization of Squad? 

Share this post


Link to post
Share on other sites

I've got an i7 2600k 3.40 GHZ, 8 GB of Ram and AMD radeon HD7850 1 GBs. All the graphic settings are on low i just got post proccesing on high and playing with 1920x1080 resolution I am barely getting 30-45 frames in full server, What's wrong with my system specs ?  Is it not covering the medium specs of the game ? Or is it just from the optimization of Squad? 

Optimization and the HD 7850 is nothing fancy, recommended to have a GPU with 2 GB of VRAM

Share this post


Link to post
Share on other sites

I have an i5-2500k, 8GB DDR3 RAM and a 780 GTX and netting around 50-70 FPS on a full server and everything maxed out. You might want to consider trading in the video card.

Share this post


Link to post
Share on other sites

You're playing an Unreal Engine 4 game with an AMD gpu. This is most likely the cause. The UE4 devs are working on optimisations tho for AMD, and ofcourse the Squad devs are constantly working on improving the game itself aswell. Give it some time and you should be able to play on better settings than low.

Share this post


Link to post
Share on other sites

You're playing an Unreal Engine 4 game with an AMD gpu. This is most likely the cause. The UE4 devs are working on optimisations tho for AMD, and ofcourse the Squad devs are constantly working on improving the game itself aswell. Give it some time and you should be able to play on better settings than low.

the optimization issues seem to only affect AMD CPUs not GPUs.

Share this post


Link to post
Share on other sites

i have gtx 960 i5 4440 but only problem i have is on Kohat, and it's really annoying... anyone else have problem with trees brining down huge FPS after awhile

Share this post


Link to post
Share on other sites

i have gtx 960 i5 4440 but only problem i have is on Kohat, and it's really annoying... anyone else have problem with trees brining down huge FPS after awhile

Kohat runs pretty poorly even compared to other maps it seems. Fools road runs better and it's full of foliage.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×