Jump to content
Kpotis

Refund Please

Recommended Posts

Hi

 

I purchased this game on Steam and Acknowledge it's an Alpha. 

 

That being said, I would expect having a 4ghz Intel CPU, GTX780ti & 24GB of DDR3 I would get some descent frames. 

 

I really, really want to play because even though the game is stuttering it seems really good. I'm frustrated because my machine 

should be able to handle it no bother, like every other game I play on Ultra. 

 

I have trawled forums / youtube videos to find fixes and applied them with slight gains in performance but nowhere near what I'd expect, 

even from an Alpha. I feel very frustrated I purchased this game in it's current state, gobsmacked you are actually selling it and request a refund please.  

 

Tried various .ini fixes, disabled hyperthreading, changing settings in game & bios etc with no joy. 

 

I hear people with AMD chips are having terrible performance. Judging by the performance issue I'm having with Intel, it must be severe. 

Share this post


Link to post
Share on other sites

I feel very frustrated I purchased this game in it's current state, gobsmacked you are actually selling it and request a refund please.

It's fine asking for a refund but when you say stupid shit like that I wouldn't personally expect a warm response from the community, I'm running the game at 720p with an i5 and a 560Ti with only 6GB of RAM and the lowest FPS I get is about 35-40 on Fools Road. Given the stage of development that the game is in I think it runs really well for people who aren't running AMD based systems, which really isn't Offworld Industries fault at all.

In this particular case it looks like you're just unlucky, what CPU do you have exactly and what FPS are you getting in populated servers?

Share this post


Link to post
Share on other sites

What are your in-game video settings?

 

Also,

 

gobsmacked you are actually selling it

gobsmacked I already played it more than 300 hours. Most of them with a HD7870XT video card, and on 1440p. Low settings, but it played just simply great. THANK THE LORD that they were actually selling it. It's only two months into Steam EA and I already got its value out of it two times over. With probably at least a year of development yet to come, and even more playtime and/or content afterwards... Bad deal? I don't think so :ph34r:

 

Recently updated to a top-of-the-line video card just to be able to play this game on epic. It's... epic. :)

Share this post


Link to post
Share on other sites

Animation is being re-worked,when done performance will increase.You've purchased a Alpha game...This means you need to be patient!

 

What performance issues are you having?

Share this post


Link to post
Share on other sites

Go for it, and try turning off some of the new settings that got added in with the update (lens Flare, Motion Blur, etc.)

 

Here are the Setting's Im running. 

(GTX 960) Running 50FPS-70FPS on Average with these settings 150ish on Jensens Range/Training map. I have my Textures set to 2gb only because that's what my GPU Vram is.

 

alLbVb7.png

 

dIqZERT.png

 

If that still doesn't work out, well, I mean it's your money that you worked to earn. Do whatever you want with it. 

 

 

Result:AJd2K6X.jpg

Share this post


Link to post
Share on other sites

If you purchased Squad via Steam, it is my understanding that you have to request your refund through Steam.

http://store.steampowered.com/steam_refunds/

 

You can request a refund for nearly any purchase on Steam—for any reason. Maybe your PC doesn't meet the hardware requirements; maybe you bought a game by mistake; maybe you played the title for an hour and just didn't like it.

It doesn't matter. Valve will, upon request via help.steampowered.com, issue a refund for any reason, if the request is made within fourteen days of purchase, and the title has been played for less than two hours. There are more details below, but even if you fall outside of the refund rules we’ve described, you can ask for a refund anyway and we’ll take a look.

Share this post


Link to post
Share on other sites

Thanks Minority I'll Try that out also, just finishing dinner. 

 

Chill out eclipse and I don't see anything you could call stupid shit about my comment

 

I think the game could potentially be epic and I really want to work. 

Think it's reasonable to be slightly frustrated, Alpha or not. It should be a free Alpha until the bugs are fixed. 

 

I've tried it on epic / High / Medium

 

Strange it seems when I'm moving it's laggy & stuttery but moving the mouse alone it's really smooth. 

Share this post


Link to post
Share on other sites

Trust me dude when i say this when you have a rig that meets either the minimum or recommended or even exceeds it don't necessarily mean the game will run smoothly or even at all and even if we have the same setup as someone else we still could have completely different results and it isn't always the games fault. PC gaming isn't like console where you stick a game in and off you go our experience is a little more complex. fitting components is one thing but configuring your system in order to run everything flawlessly is a challenge on it's own.

 

What is your setup in regards to internal hardware? overclocked or not? It might sound stupid but allot of the time gaming issues can be a result of a misconfiguration machine but if you provide more information somone may be able to shed some light and offer assistance.

Share this post


Link to post
Share on other sites

Are the drivers up to date on the GFX card?

Power supply wattage is?

 

Also, you should be able to afford to set your Texture VRAM to max 3GB

 

 

MSI afterburner will allow you to see what your hardware is really running at and allow for a better understanding of what shortcomings may be present in your system.

Share this post


Link to post
Share on other sites

You mention that your processor runs at 4 ghz. That doesn't tell us much. Tell us which processor you're running.

 

Even my first Dell computer in 2004 had a 3.4 ghz processor. It was single core pentium 4, however!

Share this post


Link to post
Share on other sites

There are several other factors that could be contributing to your issues...

 

What sort of internet connection?

Have you rebooted your modem and or router lately?

Have you got other things running in the background?

Are other people where you live watching netflix or similar?

Share this post


Link to post
Share on other sites

Chill out eclipse and I don't see anything you could call stupid shit about my comment

 

 

I feel very frustrated I purchased this game in it's current state, gobsmacked you are actually selling it and request a refund please.

It's the gobsmacked part. I have 200hours on the game. Like Karm said, i'm extremely happy they are actually selling it.

Share this post


Link to post
Share on other sites

Thanks Minority followed your settings and getting 106fps...game looks pretty poor though...like its from 10+ years ago

Share this post


Link to post
Share on other sites

I have Intel 3.9ghz, GTX 780ti and 16gb DDR3 and get decent fps. Around 170-180 on Jensens Range. Everything Epic with 120% Res scale but Shadows on medium. Turn off the in game MSAA & FXAA but turned them on again in the Nvidia CP. In empty servers I can still get 60 fps and above 60 on all the maps generally. 

 

In populated games though things take a dive which the devs have said is down to the way the animations are done. They're working on that but, as you can imagine, it's a big task to work back through so you'll have to be patient. It might be in the next patch but the devs won't make any promises in that regard.

Share this post


Link to post
Share on other sites

Ok, but what is you cpu? I got i5 4690K at stock speed and 760 gtx. No issue here. All smooth. So it gotta be your cpu

Share this post


Link to post
Share on other sites

Dude, I have a freaking MSI laptop (hooked up to a monitor of course) running a GTX 860m which is a laptop card, along with an intel i7 3.2ghz and 12gb ddr3 game installed on my 128gb m2 SSD as well.  And I get good framerates at 1080p with a mixture of low (shadows), medium (most), and high (view, effects) settings.  I have a hard time believing your rig is getting unplayable performance.  I would have to say there is something else going on with your system, or you literally have EVERY setting on Epic.  OR you just want a refund for another reason.  It is not an issue with the game.  If I can get 40-60 fps on a 72 player server with a mixture of settings at 1080p and the game looking beautiful then you should be able to as well.

 

When was the last time you did a windows refresh? 

 

What kind of hard drive is the game installed on?

 

When was the last time you ran antivirus/anti malware?

 

Any nonsense running in the background?

 

Etc.  Just curious.  Because whatever is happening it isnt the game's fault.  Your system is far superior to mine.  Ill take a screenshot of my settings if you want.  The game still looks gorgeous on my system too. 

Share this post


Link to post
Share on other sites

Ok, but what is you cpu? I got i5 4690K at stock speed and 760 gtx. No issue here. All smooth. So it gotta be your cpu

 

I have same processor but GTX 970 nVidia MSI 4Gb. I have overclocked my processor from 3.4GHz to 4.2GHz and it's stable (Very cool box). So did I overclock GPU too with MSI Afterburner. 16Gb RAM. I have adaptive V-sync on from nVidia settings and 144Hz Monitor. I have locked 144fps when playing. All ultra except shadows now and no motion blur nor lens flares. I am just stunned how good this game runs at this stage of Alpha 4.0. But some softwares may slow games too. I have just bought and build computer. Under weeek old with fresh WIN 10 64-bit and SSD drives...

 

edit: Oh and I have BenQ XL2411Z monitor and I use blur reduction option. It helps a helluva lot. :)

 

http://gaming.benq.com/gaming-monitor/xl2411z

 

 

Motion Blur Reduction for Extra Clarity Throughout the Game

For a long time, the refresh rate of regular LCD displays has always been the key factor that puts professional gamers off from switching their CRT screens. Now, with BenQ’s new Motion Blur Reduction technology, gamers can finally set their mind at ease! Following is a simulated in-game video, you will see how BenQ Motion Blur Reduction helps you aim down targets with more precision comparing to the screen without.

Share this post


Link to post
Share on other sites

Hi

 

I purchased this game on Steam and Acknowledge it's an Alpha. 

 

That being said, I would expect having a 4ghz Intel CPU, GTX780ti & 24GB of DDR3 I would get some descent frames. 

 

I really, really want to play because even though the game is stuttering it seems really good. I'm frustrated because my machine 

should be able to handle it no bother, like every other game I play on Ultra. 

 

I have trawled forums / youtube videos to find fixes and applied them with slight gains in performance but nowhere near what I'd expect, 

even from an Alpha. I feel very frustrated I purchased this game in it's current state, gobsmacked you are actually selling it and request a refund please.  

 

Tried various .ini fixes, disabled hyperthreading, changing settings in game & bios etc with no joy. 

 

I hear people with AMD chips are having terrible performance. Judging by the performance issue I'm having with Intel, it must be severe. 

 

my friend wait  :)

 

Should not refund before you find cause of your problem,

 

there seems something really wrong with your hardware and performance in all honesty to help you out . . 

squad runs very well on my amd system (WAAAY less powerful gpu). 

 

It's almost impossible your 780ti hasn't gotten SOLID fps!

cause for reference, I have a amd 5ghz 8 core and a mere 280 at stock clocks mind you lol 

run everything maxed out even sweetfx and still in 70p servers get @ 30 fps. epic everything. 8 gb 1866 mem on 990fx board... 

 

what kind of fps are you getting anyhow? 

temps cpu / gpu full load?

what is your psu?

what kind of cpu you have? 

os?

overclocked anything?

 

i am thinking perhaps the psu is a little short? is your system stable?

drivers updated? windows 10?

 

refund I wouldn't recommend my friend this looks something much different of a problem dont worry we will find it and you will play squad finely :) 

 

sorry for many question but in order to find problem need to know much :) :)

 

md

Share this post


Link to post
Share on other sites

Hi

 

I purchased this game on Steam and Acknowledge it's an Alpha. 

 

That being said, I would expect having a 4ghz Intel CPU, GTX780ti & 24GB of DDR3 I would get some descent frames. 

 

I really, really want to play because even though the game is stuttering it seems really good. I'm frustrated because my machine 

should be able to handle it no bother, like every other game I play on Ultra. 

 

I have trawled forums / youtube videos to find fixes and applied them with slight gains in performance but nowhere near what I'd expect, 

even from an Alpha. I feel very frustrated I purchased this game in it's current state, gobsmacked you are actually selling it and request a refund please.  

 

Tried various .ini fixes, disabled hyperthreading, changing settings in game & bios etc with no joy. 

 

I hear people with AMD chips are having terrible performance. Judging by the performance issue I'm having with Intel, it must be severe. 

 

There's a lot of topics out there to help you get a decent amount of FPS

Share this post


Link to post
Share on other sites

~This is the first Alpha that I can honestly say feels really polished as a tactical infantry sim. Forget the fact that this game is only going to improve with further updates.. If they were not to do anything more, then I would still pump more hours of adrenaline filled play into this game...

 

As for frames, keep trying to fiddle wiith the settings, as mentioned there are many settings combinations, bear with it. Im sure further optimisations will come.

 

SG

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×