Jump to content
Spectral

Audio lag temp fix

Recommended Posts

If you are on AMD and notice lag issues when players are using comms. Please go into settings and disable all audio effects as a temporary fix!

Share this post


Link to post
Share on other sites

If you are on AMD and notice lag issues when players are using comms. Please go into settings and disable all audio effects as a temporary fix!

Do you want us to play this game without sounds?

lrDG7hK.png

Share this post


Link to post
Share on other sites

Do you want us to play this game without sounds?

lrDG7hK.png

haha.

 

Just make sure radio filter is disabled...

Share this post


Link to post
Share on other sites

I'm only now since the recent update experiencing problems when a particular member of the squad uses VoIP. Not ideal, changing stereo settings and disabling effects doesn't seem to help either. 

 

Please hotfix asap! I miss playing :)

Share this post


Link to post
Share on other sites

So I've been trying all these various "VOIP LAG" fixes to no avail BUT finally found the fix that actually has worked all night last night. Last night was the FIRST time I was able to play without having the issue even ONCE.   The true fix was to completely delete the entire "CLASSES" folder under Squad>Squad>Content>Audio ....doing so has resolved the problem without any signs of something going wrong with any audio both voice and in-game sound effects.

Share this post


Link to post
Share on other sites

@STEALTHKILLER, now am curious.

 

Before you applied these drastic measures (of deleting a folder),

did you set the audio quality in game to low + restart the game?

 

see screenshot:

Spoiler

HiYG9G3.png

+Requires Restart

^ AFAIK, this should fix the "VOIP LAG" issue.

 

What CPU do you have?

Share this post


Link to post
Share on other sites

@CompanyXO

Unfortunately setting the audio to Low and resetting did absolutely nothing for the issue at least for me.  Removing the "Classes" folder has had zero effect on the game itself, game audio, or VOIP but has definitely 100% removed the VOIP Lag.  I even originally did the "Low" trick along with turning the Radio Filter "Off" (something else that was mentioned somewhere) and that combined still didn't fix the VOIP Lag for me. I have a FX 9350 for my CPU!

Share this post


Link to post
Share on other sites
1 hour ago, STEALTHKILLER said:

Unfortunately setting the audio to Low and resetting did absolutely nothing for the issue [...]

I hope you meant restarting the game.

 

anyways, interesting.

I guess the RadioVoice.uasset is still the culprit. (which is in the classes folder)

 

FYI:

We had this already around February.

http://forums.joinsquad.com/search/?type=all&q=RadioVoice.uasset

OWI then implemented the low audio setting especially for AMD CPUs.

No idea why this low audio setting doesn't work as intended on your PC.

Share this post


Link to post
Share on other sites

Yes I meant "restarting" the game, did nothing for me.  The fix that was given to remove the "RadioVoice" deal also did nothing for me.  Unfortunately the only fix was taking out that entire folder.  Not sure why those fixes didn't work for me but I'm just happy that I can even play the game now.  Not the greatest FPS numbers for me (hovering between 8-30) but before that it was completely unplayable

Share this post


Link to post
Share on other sites
Quote

So I've been trying all these various "VOIP LAG" fixes to no avail BUT finally found the fix that actually has worked all night last night. Last night was the FIRST time I was able to play without having the issue even ONCE.   The true fix was to completely delete the entire "CLASSES" folder under Squad>Squad>Content>Audio ....doing so has resolved the problem without any signs of something going wrong with any audio both voice and in-game sound effects.

 

This gave me decent fps ( between 25 fps - 35 fps ) and cpu usage ;

BUT no in game music, while playing i cant hear footsteps, and game plays looped random reload sounds ( also grenade throwing )

 

Nothing works for me so far in online play ive got horrible lag spikes fps drops from give or take 45-30 to absolute zero,

ive got settings maxed out and i got 50 fps easly ( at firing range - only, we cant play offline different maps )

 

Also tried setting adio on low with restart and turning off all audio driver effects ( with 7.1 system )

Edited by Odrey
Added : "Also tried setting adio on low with restart and turning off all audio driver effects ( with 7.1 system )"

Share this post


Link to post
Share on other sites
On 8/15/2016 at 2:45 AM, Odrey said:

 

This gave me decent fps ( between 25 fps - 35 fps ) and cpu usage ;

BUT no in game music, while playing i cant hear footsteps, and game plays looped random reload sounds ( also grenade throwing )

 

Nothing works for me so far in online play ive got horrible lag spikes fps drops from give or take 45-30 to absolute zero,

ive got settings maxed out and i got 50 fps easly ( at firing range - only, we cant play offline different maps )

 

Also tried setting adio on low with restart and turning off all audio driver effects ( with 7.1 system )

Did you remove the entire "Audio" folder or the "Classes" folder under the "Audio" folder?  Removing the entire "Audio" definitely gives the "reloading" audio loop and you won't be able to hear various audio cues or the music.  Deleting just the "Classes" folder 100% got rid of my VOIP Lag issue without affecting the game audio or music whatsoever.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×