Jump to content
masterlooser

7.1 - USB - Headphones Soundissues

Recommended Posts

 

ppl saying the sound cuts off, which it actually isnt, its more of a "trying to playback a broken file or whatever" sound-cut off.

 

cant play and devs dont seem to know or dont really care about how to fix this :(

 

here have a lil video

 

Share this post


Link to post
Share on other sites

I recommend using stereo for now, 7.1 isn't at the top of the list I don't think. It will be implemented ofcourse...

Share this post


Link to post
Share on other sites

I recommend using stereo for now, 7.1 isn't at the top of the list I don't think. It will be implemented ofcourse...

 

the weird thing is, sometimes it works for an hour with no problems at all, and than it just happens literally as soon as i jump in. cant be that hard to fix, if its working sometimes already, right?

 

i dont wanna sound rude, but u telling me to use stereo is like me telling u to use an oldschool fat screen just because the game turns black if u are using an LCD monitor..

Share this post


Link to post
Share on other sites

im using a corsair h1500 with 7.1 and I have no problems at all.

never had.. maybe something with the sound card itself? update drivers?

Share this post


Link to post
Share on other sites

nPBEGTc.jpg

 

I know some USB-headsets are bound to their integrated sound cards (leaving you no option for customization) but surely Logitech have covered that in their software?

Share this post


Link to post
Share on other sites

nPBEGTc.jpg

 

It's probably not part of your problem, but your G35 is only simulating surround sound.

 

I know some USB-headsets are bound to their integrated sound cards (leaving you no option for customization) but surely Logitech have covered that in their software?

 

 

if i go into the options u showed, all i have is 7.1, nothing else.

i have a simple switch on my headphones which disable 7.1, but the problem remains.

my drivers are uptodate.

 

i think i said it in the video, but i dont care if its simulated or not, in the end it sounds by far better than my in-ear 20$ earplugs.

Share this post


Link to post
Share on other sites

the weird thing is, sometimes it works for an hour with no problems at all, and than it just happens literally as soon as i jump in. cant be that hard to fix, if its working sometimes already, right?

i dont wanna sound rude, but u telling me to use stereo is like me telling u to use an oldschool fat screen just because the game turns black if u are using an LCD monitor..

Yeah, I mean if everything isnt that hard to fix the game would be finished. Think about it bro. They are trying to fix performance, bugs, crashes, & other stuff that has a higher priority than the luxury of 7.1, they will fix it eventually. Untill then I recommend stereo.

Share this post


Link to post
Share on other sites

Yeah, I mean if everything isnt that hard to fix the game would be finished. Think about it bro. They are trying to fix performance, bugs, crashes, & other stuff that has a higher priority than the luxury of 7.1, they will fix it eventually. Untill then I recommend stereo.

 

i wish i had the luxury of playing the game with sound.

i dont care if its 7.1, i just wanna use my headphones and play the game without it blowing half way up whenver someone speaks.

i know u prolly dont have the problem, but i cant play the game with that.

 

and if they can fix characters not having pants on, than they surely can focus on making the game playable in first place right?

pants > sound?

Share this post


Link to post
Share on other sites

Pretty sure all 7.1 headphones can be set to stereo. If games don't support 7.1, which currently this one doesn't because it's not fixed yet. They are still messing around with the sounds. They changed the gun fire last patch. Go to properties and set your headset to stereo, that will fix the problem until they fix 7.1!

Share this post


Link to post
Share on other sites

  • Go to the Control Panel.

  • Select Hardware and Sound.

Click Sound.

Go to the Playback tab.

Right click the Logitech Surround Sound Headset G35 and select "Configure Speakers".

Click 'Next".

Uncheck all the speakers listed.

Click "Finish".

Try this ?

Share this post


Link to post
Share on other sites

 

  • Go to the Control Panel.
  • Select Hardware and Sound.
  • Click Sound.
  • Go to the Playback tab.
  • Right click the Logitech Surround Sound Headset G35 and select "Configure Speakers".
  • Click 'Next".
  • Uncheck all the speakers listed.
  • Click "Finish".

Try this ?

 

 

tried.. didnt work

i mean i could set it to stereo but i still had these sound bugs :)

Share this post


Link to post
Share on other sites

I had the same sound problem the op mentioned when using gamescom 780 plantronics. Tried all suggested tweaks. Nearly gave up. In the end what worked was actually uninstalling the headphone control panel/driver which seemed to force them into stereo. I wouldn't call this a fix as the sound quality of the headphones is noticeably poorer without the driver. When the 7.1 did work in squad, it sounded amazing. Hoping for a 7.1 fix soon!

 

Hope this helps someone, this problem drove me slightly mad. 

Share this post


Link to post
Share on other sites

Pretty sure all 7.1 headphones can be set to stereo. If games don't support 7.1, which currently this one doesn't because it's not fixed yet. They are still messing around with the sounds. They changed the gun fire last patch. Go to properties and set your headset to stereo, that will fix the problem until they fix 7.1!

I wish that were true but it's not the case. I have Logitech g930 and the only option is 7.1 so I had to switch to my hyperX Cloud headset because they can do stereo and quadrophonic, I have the same issue where it's cutting my FPS down to 5 when people talk over squad VoIP.

Share this post


Link to post
Share on other sites

I had many issues like this with my G35. Skyrim was the worst for this issue, and I put it down to the G35 not being a true 7.1 device. It is digitally produced surround sound effect and so I think it struggles with processing multiple voices from multiple directions. Think of how many gunshots, foot steps, ambient sounds etc. that the drivers are trying to deliver to the headset, in the right balance to make it sound like 7.1.

 

I have a true 5.1 headset and I have not had a single issue with squad, because my soundcard is sending the audio signals through individual channels to actual drivers, not just a stereo headset with some bass drivers. 

I really don't see this being a developer issue right now, as surround sound definitely works, and if there is an issue will it really be down to the squad devs to isolate and correct, or will it be something that EPIC have to address within UE4 its self?

Share this post


Link to post
Share on other sites

From the responses here, the issue seems to be the g35 itself or the drivers for it.

Does your computer have an onboard soundcard? You could use that with stereo headphones.

Share this post


Link to post
Share on other sites

I've got Roccat Kave true 5.1 analog sound headphones with 6 physical dynamics and I play on 5.1 in Windows Control Panel. Using Asus Xonar DG 5.1 sound card. All 6 channels working just fine in game.

 

The game sounds pretty good considering it's an alpha version of the game. Positioning already over9000 times better than in CS 1.6, CS:GO, Cattlefield 3, Cattlefield 4 and Cattlefield: Hardline altogether. I have no any problems in determining enemy position once I heard him running/shooting.

 

Don't set 5.1/7.1 in control panel if you're using fake 5.1/7.1 virtual surround sound stereo headphones.

Share this post


Link to post
Share on other sites

Don't set 5.1/7.1 in control panel if you're using fake 5.1/7.1 virtual surround sound stereo headphones.

I'm running a Soundblaster Z with stereo headsets with virtual surround. Windows is set to 5.1 and I have no issues with sound so far.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×