Jump to content
FearFactor

Input.ini - bind console-commands to some keys doesnt work

Recommended Posts

I tried to bind useful console commands to keys by editing C:\Users\<username>\AppData\Local\Squad\Saved\Config\WindowsNoEditor\Input.ini manually:

 

ActionMappings=(ActionName="DisableHudWidgets",Key=I,bShift=False,bCtrl=False,bAlt=False,bCmd=False)
ActionMappings=(ActionName="HighResShot 4",Key=O,bShift=False,bCtrl=False,bAlt=False,bCmd=False)
ActionMappings=(ActionName="Stat FPS",Key=P,bShift=False,bCtrl=False,bAlt=False,bCmd=False)
 

 

 

Sadly it doesnt work. :(

 

Is the Input.ini not designed to allow things like that ... or what im doing wrong?

Share this post


Link to post
Share on other sites

I may be wrong, but from my understanding of key binds.

In order to be a bindable command it has to be a registered action tied to a command/function/method.

Like I said though I could be totally wrong. I haven't toyed with file edit binds yet. I just got my in game binds all dialed in.

Had an after thought. Might try wrapping the commands with the quotes in single quotes. Due to being a console command.

'"STAT FPS"'

Things I am curious about.

Are the key names supposed to be wrapped in quotes?

Does bCmd=false refer to the Windows command key or does it refer to in game command? I imagine the former, but thought I'd ask and see if we get any replies.

Share this post


Link to post
Share on other sites

Maybe a console command isnt a valid "ActionName". :huh:

 

- Keynames dont have to be quoted.
- tried wrapping with ' and setting bCmd=True ... without results

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×