Jump to content

vini2003

Member
  • Content count

    2
  • Joined

  • Last visited

About vini2003

  • Rank
    Grunt
  1. Sorry for the really late response, seriously. After some googling, talking with some people, trying some more stuff and reading your answers I'm sure it's my network card. I'll be doing what Psyrus suggested. Thanks for the help!
  2. Hello. I bought Squad yesterday, however I'm having the same problem as many others: servers do not show up, nor can I enter the training range. From what I've read, I think that the problem is my motherboard's drivers. It's a Gigabyte G1.Guerrila, and it uses Killer drivers. From what I've seen, the Killer Network Manager causes the issue that I'm having. I tried to do what was suggested: downloading the standalone drivers without KNM. However... they do not work. My motherboard uses E2100 drivers, and the new drivers aren't compatible with it. So I'm stuck with the old drivers that do not have a standalone version that comes without KNM (as far as I'm aware). So, my question is if there's any hope about getting Squad to work on my PC. Maybe someone else has some ideas to solve my problem, or knows about a standalone E2100 driver. Thanks to anyone who is taking his / her time to read my post, I hope I can start playing Squad in the near future. (By the way, yes, I've tried most of the other possible ways to fix this problem. They did not work.) Edit: Well, I can play with a WiFi adapter, but the ping is astronomically high.
×